× Forum Header

Steppers stuttering

More
23 May 2022 11:36 - 23 May 2022 11:49 #243605 by remon_v
Steppers stuttering was created by remon_v
Hello,

I just got my machine working with LinuxCNC and I got a bit off a problem.
I see the machine stuttering when running a program. 
My first thought was it's something in the wiring or something mechanically... but then I thought it might be in the timings.
Something I need to explore, but not sure how.

This doesn't occur when I jog the machine, but only when I run a program... the faster it goes the stutter inceases exponentionally, even when I do air milling.
From what I can see it has more trouble in arcs or corners.

Some info about the machine:
I have a double gantry machine (MPCNC) with 5 steppers and 5 drivers, 2 for X, 2 for Y and 1 on Z-axis.
The drivers I'm using are Leadshine DM542's which I couldn't find timings for.... so maybe there lies a problem.

Info about the PC:
Dell Optiplex 780
Core2duo E8500
8 GB RAM

I've attached my INI and HAL file, could someone have a look at stepper timings and base/servo thread?
Anyone has a clue what could be the problem?

Thans in advance!

EDIT: After running the driver tuning, switch the '4' it's becomming way less, but it's still there...

 
Attachments:
Last edit: 23 May 2022 11:49 by remon_v.

Please Log in or Create an account to join the conversation.

More
23 May 2022 14:32 #243615 by tommylight
Replied by tommylight on topic Steppers stuttering
What version of LinuxCNC?
What kernel version?
Do you get latency warnings?
setp parport.0.reset-time 2500
that is to low for cheaper drives, set it to at least 5000
If you do get latency warnings, change
BASE_PERIOD = 60000
to 100000 or 150000 or 200000 until you get no warnings.
The following user(s) said Thank You: remon_v

Please Log in or Create an account to join the conversation.

More
23 May 2022 14:40 #243617 by remon_v
Replied by remon_v on topic Steppers stuttering
Thanks for the reply Tommy!

Version of LinuxCNC:
LinuxCNC 2.8.2 Debian 10 Buster PREEMPT-RT ISO

I don't get latency warnings.

I'll change the 'setp parport.0.reset-time 2500' to 5000

Please Log in or Create an account to join the conversation.

More
23 May 2022 15:30 #243619 by remon_v
Replied by remon_v on topic Steppers stuttering

setp parport.0.reset-time 2500

I changed this to 5000, but no luck...

These are the timing settings in the HAL file, but why steplen 1 and stepspace 0? 
setp stepgen.0.steplen 1
setp stepgen.0.stepspace 0
setp stepgen.0.dirhold 30000
setp stepgen.0.dirsetup 28000

Please Log in or Create an account to join the conversation.

More
23 May 2022 15:59 - 23 May 2022 16:02 #243621 by PCW
Replied by PCW on topic Steppers stuttering
When the parport components reset mode is used,
the steplength is set by the reset-time parameter and
stepspace must be set to 0 for the reset mode to work
with the stepgen.

There is a more complete description in the hal_parport manual page:

man hal_parport
Last edit: 23 May 2022 16:02 by PCW.
The following user(s) said Thank You: remon_v

Please Log in or Create an account to join the conversation.

More
23 May 2022 16:11 #243622 by remon_v
Replied by remon_v on topic Steppers stuttering
Thanks for the explaintion!

I'm still not sure what value I need to set the dirhold and the dirsetup to...

Please Log in or Create an account to join the conversation.

More
23 May 2022 16:24 #243624 by tommylight
Replied by tommylight on topic Steppers stuttering
The official ISO uses the Preempt-RT kernel so it will have bad latency on older PC's, try installing the RTAI kernel :
linuxcnc.org/docs/2.8/html/getting-start...#cha:Installing-RTAI
Then use
uname -a
in a terminal to check what kernel is in use, if it is not the RTAI one, reboot and hold down the SHIFT key till you see ther GRUB menu, then choose the RTAI entry and press enter.

Please Log in or Create an account to join the conversation.

More
23 May 2022 17:46 - 23 May 2022 17:52 #243629 by remon_v
Replied by remon_v on topic Steppers stuttering
If I can't fix it I will try the RTAI kernel, but I'm not sure how to do that yet. I can install it when I'm in Linux? Or should I download an ISO first?

At the moment the problem is 99% solved.

I put the reset time at 5000 and the dirhold and setup at 10000.
BTW lower is better right?
Last edit: 23 May 2022 17:52 by remon_v.

Please Log in or Create an account to join the conversation.

More
23 May 2022 23:44 #243657 by tommylight
Replied by tommylight on topic Steppers stuttering
Just occurred to me, if you are using a cheap BOB with optocouplers, nothing under 100000 for base period will work correctly.
Also reset time of 8000 to 10000 is needed for those.
The following user(s) said Thank You: remon_v

Please Log in or Create an account to join the conversation.

More
24 May 2022 11:18 #243675 by remon_v
Replied by remon_v on topic Steppers stuttering
Thanks Tommy, I've changed the rest time to 8000 and base period to 100.000

Please Log in or Create an account to join the conversation.

Time to create page: 0.131 seconds
Powered by Kunena Forum