LENOVO P500

More
24 Jul 2021 23:48 #215820 by JuniorC
LENOVO P500 was created by JuniorC
I have the opportunity to get a Lenovo P500, that my work is retiring. Has anyone used the brand and model to running LinuxCNC? If so how did it do?
 I know I'll have to get a parallel port card or a Mesa card. 
  I have attached the specs on the computer.
Thanks for your time and help.  



  
Attachments:

Please Log in or Create an account to join the conversation.

More
27 Jul 2021 22:21 #216077 by andypugh
Replied by andypugh on topic LENOVO P500
Looking at motherboard photos, there might be a parallel port header at the bottom near the SATA connectors.

It seems like a lot of PC, maybe more than necessary. Is it very cheap?

Please Log in or Create an account to join the conversation.

More
28 Jul 2021 19:21 #216143 by JuniorC
Replied by JuniorC on topic LENOVO P500
They are basically scraping the computer. They are installing all new PCs. I will have to get a new drive. They will be removing the original.

Please Log in or Create an account to join the conversation.

More
01 Aug 2021 00:36 #216545 by andypugh
Replied by andypugh on topic LENOVO P500
You could try booting one from the LiveUSB and running the latency test. (unless USB boot is disabled, which is entirely possible with a company PC)

In fact, make absolutely sure that your company is happy to unlock the BIOS etc before giving it to you, or you will get nowhere.

TBH that looks more like the CAD/CAM PC than the CNC PC.

Please Log in or Create an account to join the conversation.

More
06 Aug 2021 05:26 #217026 by JuniorC
Replied by JuniorC on topic LENOVO P500
Well they finally scrap the computer, but someone got to it before I was able to.  The memory, processor, and video card have been removed.  Along with the processor socket being damaged in the process.  But the plus side is, they had a Lenovo P520 that they were getting ready to scrap.  It's missing a video card,  which is not a big deal.  And the bios is unlocked.  Hope to have some updates by this weekend on the latency test. 

Please Log in or Create an account to join the conversation.

More
11 Aug 2021 03:42 #217465 by JuniorC
Replied by JuniorC on topic LENOVO P500
I finally got LinuxCNC 2.8.2 installed. Ran the latency test and it is not good. I'm running a MSI GeForce GT 1030. Running all four cores are operating. I have not isolated any of the cores. Any suggestions for better times.  I'm a little disappointed.    
Attachments:

Please Log in or Create an account to join the conversation.

More
11 Aug 2021 09:24 #217490 by tommylight
Replied by tommylight on topic LENOVO P500
What does
Uname -a
In a terminal say?

Please Log in or Create an account to join the conversation.

More
12 Aug 2021 09:35 #217593 by JuniorC
Replied by JuniorC on topic LENOVO P500
Sorry for the late reply.
It said, Linux debian 4.19.0-17-rt-amd64 #1 SMP PREEMPT RT Debian 4.19.194-2 (2021-06-21) x86_64 GNU/Linux

Please Log in or Create an account to join the conversation.

More
12 Aug 2021 11:19 #217599 by tommylight
Replied by tommylight on topic LENOVO P500
Kernel seems ok, but that latency is way off.
BIOS, disable everything possible regarding hyperthreading, speed step, power savings, C states, modem, serial, even audio sometimes helps, etc.

Please Log in or Create an account to join the conversation.

More
12 Aug 2021 19:40 #217627 by JuniorC
Replied by JuniorC on topic LENOVO P500
Thank to everyone for replying.  Tommy I have turned off a few things in the bios. But i did some experimenting.  I have an old PC that I built 10 years ago. It has an Asus M3N-HT Deluxe Motherboard  along with an AMD Phenom II X4 Processor.  I installed the LinuxCNC 2.8.2.  Ran a latency test.  It  wasn't  bad but nothing to write home about. LOL. So I removed the graphics card from the Lenovo and installed it in the PC that I built and ran another latency on the Asus PC. The test was terrible. One question I have is, can a HDMI to VGA adapter cause issues with a latency test. I don't have a high end monitor.  Just an old school flat-screen with VGA only.  I have added some pictures of before and after.  Again this is on a different and older PC. 
Thanks again for the help. 
 
 
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.254 seconds
Powered by Kunena Forum