Compiling realtime kernel

More
11 Jan 2022 10:15 - 11 Jan 2022 10:17 #231427 by Tady
Replied by Tady on topic Compiling realtime kernel
Yes I know that it tells me to install python3.6 or higher. Nut I have 3.9.9 installed and I even uograded it to 3.10

I'm running ubuntu with cinnamon desktop
It is not a fresh install. It is the system I had for other things and I'm just messing with linuxcnc and ethercat
 
Last edit: 11 Jan 2022 10:17 by Tady.

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 10:18 #231428 by rodw
Replied by rodw on topic Compiling realtime kernel
So what does python3 -V report?
 

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 10:22 #231430 by Tady
Replied by Tady on topic Compiling realtime kernel
python - - version reports 3.10
That is why I am confused

Please Log in or Create an account to join the conversation.

More
More
11 Jan 2022 10:36 #231432 by rodw
Replied by rodw on topic Compiling realtime kernel
Funny, I've been playing with ethercat too!

Personally, I would regroup and follow these instructions
www.qtpyvcp.com/install/bullseye.html
It will add a few extra dependencies  for qtpyvcp you may not need but you never know...

I have a ethercat WIP project documented here with install instructons.
github.com/rodw-au/linuxcnc-cia402
The following user(s) said Thank You: Tady

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 11:46 #231435 by Tady
Replied by Tady on topic Compiling realtime kernel
Nice project! Currently I' trying to play with some Beckhoff I/O cards but I need to get linuxcnc up and running. In the past I newer had problems with building Linuxcnc-dev but Jammy seems to give me problems.

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 12:21 #231437 by rodw
Replied by rodw on topic Compiling realtime kernel
Yeh, the move to Python 3 has made it difficult to build from source and I had similar problems that broke configs on Linux Mint because the dependencies changed.

So my solution was to install an OS that only had Python 3.7 or higher and no Python 2.7 and also had a PREEMPT_RT package. I also  needed to get some newer network drivers that were in the 5.10 kernel.

In fact I adopted Bullseye while it was still testing branch.

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 13:02 #231438 by Tady
Replied by Tady on topic Compiling realtime kernel
I'm going to start from scratch... Can you advise me on kernel version best for ethecat. I mean what kernel do you use?

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 13:25 - 11 Jan 2022 13:49 #231439 by Tady
Replied by Tady on topic Compiling realtime kernel
Do you know how to control an EL2809 with "ethercat soe_write"?
ethercat slave reports

0 0:0 PREOP + EK1100 EtherCAT-Koppler (2A E-Bus)
1 0:1 PREOP + EL4132 2Ch. Ana. Ausgang +/-10V, 16bit
2 0:2 PREOP + EL1809 16K. Dig. Eingang 24V, 3ms
3 0:3 PREOP + EL2809 16K. Dig. Ausgang 24V, 0.5A

Last edit: 11 Jan 2022 13:49 by Tady.

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 21:40 #231486 by tommylight
For ethercat there is a ready made ISO by Grotius, search the forum or github.
Sorry, on the phone.

Please Log in or Create an account to join the conversation.

Time to create page: 0.198 seconds
Powered by Kunena Forum