Spindle indexing signal direction

More
13 Feb 2022 15:19 #234701 by Clive S
Is the Z index 1:1 on the spindle ?

Does the Z move the correct amount when commanding say G0 Z - 50 and it actually  moves 50mm

 

Please Log in or Create an account to join the conversation.

More
13 Feb 2022 15:29 - 13 Feb 2022 15:30 #234703 by rider-83
Yes,
I did some test a while ago to check positioning and repeatably and I'm very please with the results.
I've noticed also that feed rates per rev have to be set very low .
For example, I'm having to rough feed at around F0.05, and finish at around F0.01.
Something is amiss here.
Last edit: 13 Feb 2022 15:30 by rider-83.

Please Log in or Create an account to join the conversation.

More
13 Feb 2022 15:59 #234705 by Clive S

Yes,
I did some test a while ago to check positioning and repeatably and I'm very please with the results.
I've noticed also that feed rates per rev have to be set very low .
For example, I'm having to rough feed at around F0.05, and finish at around F0.01.
Something is amiss here.


Not sure what you mean by that !!

If you are threading can you show the gcode you are using

The feed rate is controlled by the pitch

Please Log in or Create an account to join the conversation.

More
13 Feb 2022 16:12 #234708 by rider-83
I'm away from the machine right now, so I will have to get the G76 data later.
What I'm trying to say is that the feed rates that relate to rpm seem to be out.Almost as if it is not reading the rpm encoder feedback correctly.

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 12:21 #234812 by rider-83
What would cause the encoder velocity-rpm via HALshow to jump all over?
At a commanded 100rpm we see readings drop down to 89 then upto 225.
Nothing stable around 100?

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 13:28 #234819 by tommylight
Bad encoder, bad/wrong wiring, no shielded wires, interference, bad power supply.

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 18:44 #234846 by rider-83
Yes, that's a good statement, and I don't doubt you.
However, the pitch error whilst screw cutting is perfectly consistent with each pass.
This would suggest I may have made an error in my configuration perhaps?

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 19:24 #234854 by Clive S

Yes, that's a good statement, and I don't doubt you.
However, the pitch error whilst screw cutting is perfectly consistent with each pass.
This would suggest I may have made an error in my configuration perhaps?

What is the gcode you are using?

 

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 19:39 #234857 by rider-83
G76.
I tried to cut an M10 thread (1.5p) so I could check it with a standard nut.
Thread is measuring 0.75 approx. pitch with the RPM at 500
If I alter the G97 speed and try a fresh piece of bar to screw cut again to M10, the pitch will vary as I increase the revs. The pitch becomes finer. The pitch isn't consistent with any alteration of a new RPM.
Also, when feeding with G1 , the feed rates aren't what I would usually expect.

I hope I make sense with this.

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 19:50 #234858 by Clive S

G76.
I tried to cut an M10 thread (1.5p) so I could check it with a standard nut.
Thread is measuring 0.75 approx. pitch with the RPM at 500
If I alter the G97 speed and try a fresh piece of bar to screw cut again to M10, the pitch will vary as I increase the revs. The pitch becomes finer. The pitch isn't consistent with any alteration of a new RPM.
Also, when feeding with G1 , the feed rates aren't what I would usually expect.

I hope I make sense with this.


There is more than one flavour G76

This is why I was asking to see the actual Gcode that you are using

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds
Powered by Kunena Forum