Mesa 7i80DB to retrofit 4 axis VMC

More
05 Feb 2024 19:45 #292558 by matos67
Hi,  diving now into Mesa stuff.
Cards are wired and powered up
I try to configure the 7i80-HD.
By default it is set at 192.168.1.121.
I'm able to ping it under that address but not to talk to it with mesaflash.( would like to set it to 10.10.10.10)
The answer is always no 7i80 board found !
Don't know what i'm doing wrong?

ip a gave me the following result:


64 bytes from 192.168.1.121: icmp_seq=17 ttl=64 time=0.086 ms
64 bytes from 192.168.1.121: icmp_seq=18 ttl=64 time=0.061 ms
64 bytes from 192.168.1.121: icmp_seq=19 ttl=64 time=0.077 ms
64 bytes from 192.168.1.121: icmp_seq=20 ttl=64 time=0.077 ms
64 bytes from 192.168.1.121: icmp_seq=21 ttl=64 time=0.075 ms
64 bytes from 192.168.1.121: icmp_seq=22 ttl=64 time=0.099 ms
64 bytes from 192.168.1.121: icmp_seq=23 ttl=64 time=0.076 ms
64 bytes from 192.168.1.121: icmp_seq=24 ttl=64 time=0.064 ms
64 bytes from 192.168.1.121: icmp_seq=25 ttl=64 time=0.080 ms
64 bytes from 192.168.1.121: icmp_seq=26 ttl=64 time=0.079 ms
64 bytes from 192.168.1.121: icmp_seq=27 ttl=64 time=0.076 ms
64 bytes from 192.168.1.121: icmp_seq=28 ttl=64 time=0.077 ms
64 bytes from 192.168.1.121: icmp_seq=29 ttl=64 time=0.059 ms
64 bytes from 192.168.1.121: icmp_seq=30 ttl=64 time=0.065 ms
^C
--- 192.168.1.121 ping statistics ---
30 packets transmitted, 30 received, 0% packet loss, time 29683ms
rtt min/avg/max/mdev = 0.031/0.071/0.099/0.012 ms
sdc30@sdc30:~$ mesaflash --device 7i80HD-25 --addr 192.168.1.121 --readhmid
No 7I80HD-25 board found
sdc30@sdc30:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute
       valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 8c:02:60:4c:0c:3b brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.121/24 brd 192.168.1.255 scope global noprefixroute enp1s0
       valid_lft forever preferred_lft forever
    inet6 fe80::e61c:1aa5:1106:57de/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 8c:02:60:4c:0c:3c brd ff:ff:ff:ff:ff:ff
4: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether c4:d9:87:0d:50:11 brd ff:ff:ff:ff:ff:ff
    altname wlp3s0
    inet 192.168.1.76/24 brd 192.168.1.255 scope global dynamic noprefixroute wlo1
       valid_lft 84873sec preferred_lft 84873sec
    inet6 2a01:cb10:bcb:2100:c6a7:458a:7d8e:5b8e/64 scope global temporary dynamic
       valid_lft 86363sec preferred_lft 563sec
    inet6 2a01:cb10:bcb:2100:c6d9:87ff:fe0d:5011/64 scope global dynamic mngtmpaddr noprefixroute
       valid_lft 86363sec preferred_lft 563sec
    inet6 fe80::c6d9:87ff:fe0d:5011/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
sdc30@sdc30:~$




 

Please Log in or Create an account to join the conversation.

More
05 Feb 2024 19:55 #292564 by tommylight
Change the host/PC address, you have it set to 121 at the end and that is the Mesa board address.
Set it to anything from 1-254, but not 121.

Please Log in or Create an account to join the conversation.

More
05 Feb 2024 20:21 #292572 by matos67
Thank you sir.
I'm quite ashamed.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
05 Feb 2024 22:21 #292585 by matos67
Sorry to bother you again,
i was able to send the new adress to the board with mesaflash --device 7I80DB-25 --set ip=10.10.10.10
I got the message you need to reboot to activate the new adress.
After reboot i put the computer adress at 10.10.10.1 , the connection is live but i cannot ping the 7i780 under 10.10.10.10. I have tried a scan of all adress between 10.10.10.0 and 10.10.10.255 but none gives an answer. I'm lost

Please Log in or Create an account to join the conversation.

More
05 Feb 2024 23:25 #292594 by tommylight

No idea where you got the advice to change the IP using MesaFlash, that should be avoided for new boards.
The manual clearly states to change the jumpers as in the attached picture, so W1 down, W2 up.
Disconnect the power to mesa board before moving jumpers, then try pinging the card again.
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Feb 2024 21:00 #292686 by matos67
Thank you, it's working fine now.
Sorry, I was confused by the fact they explain how to set the EEPROM ip adress with the help of MESAFLASH at page 14 of the manual.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
06 Feb 2024 21:03 #292687 by PCW
That's my fault, the 7I80DB manual should say that the default
EEPROM address is 10.10.10.10
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 16:24 #293003 by matos67
Hi, i' m trying to find the right firmware for  the 7i80DB-25 card used in my project. I need a configuration for a 7i77 card + a 7i76 card.
I would like to know the designation of a pin doing analog output in the informations given by mesaflash --readhmid .
Also i have playing around with all firmware given by mesa for these 3 cards but i can't get an option to set an analog output for an axis in pncconf. Anything else than GPIO is greyed out.

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 16:32 #293005 by PCW
7i80db_25_7i76x2_7i77x2D.bit

Would be the best firmware for this.

The analog and 24V digital outputs are done via sserial ports,
so mesaflash  will not show these directly

I don't think pncconf can make a 7I77+7I76 configuration so
its likely you would need to merge a 7I77 config with a 7I76 config

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 17:02 #293010 by matos67
Firmware is loaded.
I also understand how to edit the Hal files to get what where i want.
But here i'm stuck with pncconf.
There is no combination of 7i80+ 7i77 in the menu so i try 7i92+7i77 2x but can't edit analog outputs.
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.319 seconds
Powered by Kunena Forum