Mesa 7i96s handwheel no motion

More
22 Feb 2023 15:58 #265034 by greekart
Hello guys, i just decide to come and try learning/using linuxcnc with mesa board and i need a little push to understand.
I have connect successfully the board with motors and try to use a handwheel as mpg to move x axis unsuccessfully 3 days now :)

I start with  Gmoccapy  as gui, linuxcnc 2.8 with debian (buster) and simple setup Mesa 7i96s with one motor on X and a handwheel conected to 7i96s encoder input.

I tried many HAL settings, from PPConf, custom HAL, i homed the AXIS but all the same result. At halshow the enable axis works, scale jog works, encoder shows changing but at  Gmoccapy  nothing change.

Can someone help/point me where to look for the problem??

One more small question, Mesa 7i96s can a input used as analog? For use with potentiometer.

Thanks a lot
Panos
Attachments:

Please Log in or Create an account to join the conversation.

More
22 Feb 2023 17:30 #265042 by DrKnow65
I do not have experience with MPG yet, but I would look at connecting (net) the encoder pins to the HALUI pins in your .hal file.

A __very__ abstract example:

net [HMOT] (CARD0) .encoder.01.position => jog-x-pos

Good luck. Keep asking questions, people smarter than I should be along to help soon :)
The following user(s) said Thank You: greekart

Please Log in or Create an account to join the conversation.

More
22 Feb 2023 18:39 #265051 by PCW
Replied by PCW on topic Mesa 7i96s handwheel no motion
Is the system homed?

(axis jogs dont work until homed)

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 01:52 #265084 by greekart
Yes, always i try after i home all axis. I wonder, it shouldn't somehow tell to software (Gmoccapy) that i want to use mpg?

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 02:30 - 23 Feb 2023 02:31 #265088 by PCW
Replied by PCW on topic Mesa 7i96s handwheel no motion
Did you look at all of LinuxCNC's mpg pins to see why you are not getting motion?

halcmd show all | grep jog
Last edit: 23 Feb 2023 02:31 by PCW.

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 02:33 #265091 by cmorley
use halmeter to confirm:

axis.x.jog-scale is actually set to something besides 0
axis.x.jog-enable is actually set to 'true'
axis.x.jog-counts actually counts up and down when you spin the MPG

Let us know how that goes.

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 02:59 - 23 Feb 2023 03:00 #265092 by greekart
 

File Attachment:

File Name: halcmd_2023-02-22.txt
File Size:8 KB
I attach as txt what halcmd shows.
Attachments:
Last edit: 23 Feb 2023 03:00 by greekart.

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 03:01 #265093 by greekart
axis.x.jog-scale = 10 and change normal from input pin
axis.x.jog-enable = True and change normal from input pin
axis.x.jog-counts = 0 no changes..

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 03:41 #265095 by cmorley
ok so now you know it's something to do with the MPG.
Could be connected to wrong physical pins for the encoder number you want.
Again you can use halmeter to check all the Mesa encoder counter pins (hm2_7i96s.0.inm.00.enc0-count etc) to see if any count up and down with the MPG.

Could be physically wired wrong or something wrong with the MPG it's self.

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 03:56 #265097 by tommylight
Moved to "GmoccaPy" as it is not a driver board issue.
The following user(s) said Thank You: greekart

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.111 seconds
Powered by Kunena Forum