Getting joint 0 following error?

More
29 Mar 2020 20:52 #162022 by Catch22
Are you also using 7i77 Mesa card?

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 20:57 #162023 by PCW

Catch22 wrote: Ok, so I tried 2 other drives that I had and all motors are turning both directions now.
I tried just manually moving each axis and x does nothing, y moves -.0003 and z moves -.0003 nomatter how far I move them that's it.


Are you saying the scales are not reading correctly?

Are the 7I77 encoder mode jumpers set to match the interface type (differential or TTL)?

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 21:35 #162026 by Catch22
Not sure what they are, anilam A10 linear scales, and as for jumpers, I haven't set any.

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 21:39 #162027 by PCW
If the encoder jumpers are set for differential mode (the default) and you have
single ended encoders (common on older machines) the encoder inputs will not work

How many wires do your encoders have?

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 21:42 #162029 by Catch22
Ok they are TTL and the resolution is .0004 .

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 22:06 #162033 by PCW
OK so those will not work unless you jumper the 7I77 encoder inputs for TTL mode

(scale would be 2500.00)
The following user(s) said Thank You: Catch22

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 22:06 #162034 by Catch22

PCW wrote: If the encoder jumpers are set for differential mode (the default) and you have
single ended encoders (common on older machines) the encoder inputs will not work

How many wires do your encoders have?


It looks like 2 wires a clear and black in the control panel.

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 22:08 #162035 by Catch22

PCW wrote: OK so those will not work unless you jumper the 7I77 encoder inputs for TTL mode

(scale would be 2500.00)


When you say jumper, are you referring to moving one of the jumpers or something else?

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 22:13 #162036 by PCW
Yes, you must set the encoder mode jumpers on the 7I77 to match your encoder type
(page 3 in the 7I77 manual)
The following user(s) said Thank You: Catch22

Please Log in or Create an account to join the conversation.

More
29 Mar 2020 23:22 #162040 by OT-CNC
Old Anilam crusader?? If so, double check the black and clear coming from the motor connectors are the tach feedback. I don't remember the color of the encoder wires. They may be black and clear also? If it's a BP type knee mill, they come out of a separate harness.

Are you also using 7i77 Mesa card?

Yes I'm using the 7i77 too.

Please Log in or Create an account to join the conversation.

Time to create page: 0.101 seconds
Powered by Kunena Forum