Pendant WHB04B on LinuxCNC 2.7 / Debian

More
07 Apr 2020 20:33 #163094 by Peterdeleu
Great,

This means that the XHC-WHB04B-4 pendant will work after an update of LinuxCNC ?

If so, I'll wait ;)

Please Log in or Create an account to join the conversation.

More
07 Apr 2020 20:34 #163095 by alkabal
i think the rules file provided is wrong

try this one please
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Apr 2020 20:44 #163097 by Peterdeleu
Same problem.
I've changed the ATTR to eb93 myself a few hours ago.
I saw in the results of lsusb that it had to be eb63

Please Log in or Create an account to join the conversation.

More
07 Apr 2020 21:21 - 08 Apr 2020 12:54 #163104 by alkabal
At the end you ATTR is eb63 ? (not eb93)

if this is eb63 please try this binaries (edit : removed)

Or maybee is needed to do in the binaires folder : sudo chmod +x xhc-whb04b-6

The driver is only tested with 6 axis version.
Last edit: 08 Apr 2020 12:54 by alkabal.

Please Log in or Create an account to join the conversation.

More
07 Apr 2020 22:47 #163111 by Peterdeleu
I moved a step forward after "sudo chmod +x xhc-whb04b-6 "

But another error message now
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Apr 2020 23:06 #163118 by tommylight
There is a missing bracket on the first line of xhc-whb04b-6 file.
)

Please Log in or Create an account to join the conversation.

More
07 Apr 2020 23:18 #163120 by Peterdeleu
You mean the file in the binary folder?
I can't edit this file. It is not a text file .

Please Log in or Create an account to join the conversation.

More
08 Apr 2020 00:54 - 08 Apr 2020 00:55 #163137 by MovT
Peter.

If you have LinuxCNC 2.9 installed follow Talla83's video and use the driver he supplied in the video, if you understand German and you get the MPG running fine.

I have the XHC-WHB04B-6 running with this diver. There is one trap i can tell ou the solution if u are running in. If you try it in a fresh installation of LCNC 2.9 you will not get any errors.

Best,
Udo
Last edit: 08 Apr 2020 00:55 by MovT.

Please Log in or Create an account to join the conversation.

More
08 Apr 2020 02:34 - 08 Apr 2020 02:38 #163149 by alkabal
Attached latest binaries + exemple config for 6 axis version tested and used all this evening.
Attachments:
Last edit: 08 Apr 2020 02:38 by alkabal.

Please Log in or Create an account to join the conversation.

More
08 Apr 2020 06:51 #163163 by Peterdeleu
Still an error message :(
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.158 seconds
Powered by Kunena Forum