Neverending problems with Linux

More
17 Mar 2024 09:53 #296113 by cornholio
Try this form as I mentioned above. And you may have to enable cifs v1 as I linked to above

smb://WINDOWS_USER_NAME@IP_ADDRESS_OF_SERVER/NAME_OF_SHARE

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 10:10 - 17 Mar 2024 10:11 #296116 by denhen89
Smb1 is enabled on the windows pc. See attachment
when I try the command with the name of the shared folder, then i get failed to open "smb://192.168.1.216/cnc-files". Failed to mount windows share.

It seems to be so close, but something I blocking access to the folder.
Attachments:
Last edit: 17 Mar 2024 10:11 by denhen89.

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 10:24 - 17 Mar 2024 10:25 #296117 by denhen89
It's working!
I am really in hurry, but I added pictures of what I did. (Had to give access to "everyone" for the folder I shared. There was only access the me as a user of the windows pc)
I am very much in a hurry, so I had to go out of the workshop, but thank you very very much! 
Just one question: I couldn't anymore try out to link the shared folder on my Linux desktop, but is it possible or do I need to always enter the windows link (name and server address) to the filemanager bar?

ps: the pictures are too big so I cannot upload them before I don't make them smaller, but right now I have no time to do it. Will post later for anyone who has similar problems in future.
Last edit: 17 Mar 2024 10:25 by denhen89.

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 10:43 #296118 by cornholio
Seriously I wonder why I bother sometimes. You give someone the correct form (twice) and they ignore it.

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 10:48 - 17 Mar 2024 10:50 #296119 by denhen89
I didn't ignore anything. I did it exactly as you described. Do you mean that the link does not include the username? If so, I do type it in, but when it' opens the server then I only shows the ip, without the deskop-vtxxxx (username)

I also give permission to everyone, but in one screen I saw only the name of my windows user, but I could add "permission to everyone" so I did and then it worked.
Last edit: 17 Mar 2024 10:50 by denhen89.

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 10:57 #296120 by cornholio
For the 3rd time

smb://WINDOWS_USER_NAME@IP_ADDRESS_OF_SERVER/NAME_OF_SHARE

WINDOWS_USER_NAME
IP_ADDRESS_OF_SERVER
NAME_OF_SHARE

You only used 2 of the three.

This is why you have never ending problems, like others you leave out bits. You don't fully & completely follow the advice given. Then you get upset when this pointed out.
The following user(s) said Thank You: denhen89

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 12:08 #296123 by denhen89
No, you are wrong. I dis it EXACTLY as you described. First without the name of share, then later when you posted it to try it with the name of share I did it as well but it still showed the info about not possible to mount. Now I can access the folder without the name of the folder, because it connects to my windows server and I can see the shared folder "cnc files". I could see it also before but not access it, because the option "access to everyone" was not added in one screen. Since I added "everyone" to that screen I can access the folder.
I will upload the pictures of what I did soon when I am back home.

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 12:21 - 17 Mar 2024 12:25 #296124 by denhen89
I added the pictures now to the attachment.
This is what I did and now it's working.
Before that I had all other settings done correctly but missed out to add permission to "everyone" to the list in which before was only myself. (username od the windows pc]

Thank you cornholio and others. i wouldnt manage to get it done.
I will later check if i can create a link to that shared folder, so that I don't need to always type in the username and address, but I am happy that it's working now:)
Attachments:
Last edit: 17 Mar 2024 12:25 by denhen89.
The following user(s) said Thank You: Mecanix

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 12:35 - 17 Mar 2024 12:37 #296126 by Mecanix
Ah. "Access to Everyone". Nice one. Always wondered why I never managed to get a windows share folder to ever work, neither prompt for creds. In my case I always needed to create that 'shared folder' on the linux hdd and use samba's 777 (fwiw I use a drive letter map to it in windows). Can be accessed both ends that way...

As if nobody has access (rolleyes) @windows
Last edit: 17 Mar 2024 12:37 by Mecanix.
The following user(s) said Thank You: denhen89

Please Log in or Create an account to join the conversation.

More
17 Mar 2024 12:40 - 17 Mar 2024 12:42 #296127 by denhen89
As i wrote earlier, "I did everything as in the tutorials" when it comes to the settings on the windows pc, and i am sure this step was not mentioned, otherwise i would have done it already. Good to know that i might help other to get it to work.
The last time i did such server things between 2 windows pc was about 20 years ago.
PS: in my case its only important to share files from the windows pc to the Linux pcs in my workshop, so it is perfect as it is right now.
I will go now down to my workshop and do the same thing on the lathe pc and then i check also how to have create a shortcut to that shared folder permanently, without typing the username+address everytime i want to access that folder. 
Last edit: 17 Mar 2024 12:42 by denhen89.

Please Log in or Create an account to join the conversation.

Time to create page: 0.091 seconds
Powered by Kunena Forum