Neverending problems with Linux

More
02 Apr 2024 20:35 - 02 Apr 2024 20:37 #297464 by caretech
Just a random thought -- you've apparently been making a few network changes, plugging & unplugging cables, etc. Windows is horribly notorious for switching the Network Type back to Public again, effectively disabling file sharing. I'd give that a look and ensure the network type is Private.

I've done Samba sharing on the Linux machine, mapping that as a network drive on a Windows office PC. This lets you save gcode files from your post processor straight to the machine hard drive, and might present fewer issues than trying to keep file sharing working reliably on Windows. But it seems you might have tried this and run into issues, perhaps due to your outdated Debian version.
Last edit: 02 Apr 2024 20:37 by caretech.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
16 Apr 2024 17:00 #298387 by Lcvette
i had nothing but issues setting up network file sharing and ultimately started using syncthing which has worked flawlessly for me, i link 3 machines running linuxcnc and 2 pc's i run fusion360 on and have setup a foldershare for each machine that the post writes to and automatically updates to the linuxcnc machine file. it just works and i haven't looked back, setup took me less than 10 mminutes including installing on all machines and setting the post processor output folders, may be an option for you?

for windows installed here:

syncthing.net/downloads/

for linux, install is just temrinal command:
sudo apt install syncthing

hope this helps!

I made a small video demonstration here:

Please Log in or Create an account to join the conversation.

Time to create page: 0.080 seconds
Powered by Kunena Forum