Mesa 7i96 Stepper oscillating at idle

More
02 Oct 2021 20:01 - 02 Oct 2021 20:02 #222044 by Redneck92
Hey guys,

I´m currently still on the "dry run" of my controller without the machine itself attached.
My stepper motor is oscillating at idle. But not always only sometimes when I jog the axis. The axis DRO shows that it hunts the position for about 0.005mm.

My the encoders on my steppers count 1000 pulses. So I set the Encoder Scale to 800 for a 5mm pitch ballscrew.
I confirmed this setting by turning the motor shaft for one turn and the DRO in Axis shows 5mm.

My stepper drivers have default 400 steps per revolution so I set the microstep_multiplicator to 2.

I tried with various  PID settings to get this right and read in the forums to delete the ferror line in the hal file and stuff
but nothing seems to work.

I´m currently only testing and trying and adjusting the x axis, so only one stepper is hooked up.

Can somebody take a look on my hal and ini files? Maybe I got something wrong or out of spec?

Thank you very much in advance.

Greetings, Mike
 
Attachments:
Last edit: 02 Oct 2021 20:02 by Redneck92.

Please Log in or Create an account to join the conversation.

More
02 Oct 2021 20:24 #222047 by Redneck92
I just discovered something.

When I control the axis with MDI and say for example G0 X35.125
it works perfectly. No oscillation whatsoever.

I send the axis now for 50 60 times from X0 to X35.125 and back without oscillation.

As soon as I enter X35.123 or X35.127 it oscillates as soon as it stops.
It seems that every move where the third didgit behind the decimal point is not 0 or 5 it starts oscillating and hunting for 0.002 0.003mm.

I don´t have any idea how to fix this tough...

Please Log in or Create an account to join the conversation.

More
02 Oct 2021 21:16 #222051 by chris@cnc
The following user(s) said Thank You: Redneck92

Please Log in or Create an account to join the conversation.

More
02 Oct 2021 21:27 #222052 by Redneck92
Oh I didn't know there was a setting for this.
I'll try that out tomorrow.

Thank you very much.

I'll report back.

Please Log in or Create an account to join the conversation.

More
03 Oct 2021 11:05 #222093 by Redneck92
That absolutely did the trick.
I set the Deadband value to 0.005 and now it works just as intended.

Sometimes when I jog the axis manually at a high speed it corrects the stopping position for a split second but it stopped with the hunting.

I can fine tune this on the machine later. As for the moment, everything works perfectly now.

Thank you again very much.
The following user(s) said Thank You: chris@cnc

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.089 seconds
Powered by Kunena Forum