7i97+8i20 error function not found

More
12 Mar 2023 15:34 #266496 by saquzi
Today I tried to change x-y grayscale wires inputs between them, no affect. Also changed all of the x-y in hal between them, no affect. Also tried to change 8i20 in hal across, no affect. The problem always stays in that output linuxcnc Y- or Y+ tries to move, X seems to be working just like it should

Please Log in or Create an account to join the conversation.

More
19 Mar 2023 09:44 #267073 by andypugh
Have you done the PID tuning?

What I would do (and it isn't always easy) is to first make sure that the servos turn smoothly when given just a current command (they need to be disconnected from the axes for this).
Once you can spin a motor smoothly and at both low and high speeds, and can reverse it just by setting a negative current, then you can move on to tuning the PID controller that converts position error into motor current commands.

Disconnect a coupling, or remove a belt or something, load up LinuxCNC and then open a HAL window
halcmd -kf
unlinkp hm2....8i20.0.1.current (fill in the blanks...)
setp hm2....8i20.0.1.current  0.5
setp hm2....8i20.0.1.current  0.5
setp hm2....8i20.0.1.current  -5

etc. "exit" to finish and note that you can use tab-completion for the pin names. ie, type hm{tab} and you will get hm2_5i25.0. or similar auto-typed, up until it becomes ambiguous.

Please Log in or Create an account to join the conversation.

More
19 Mar 2023 16:30 #267088 by saquzi
Got it working pretty good. So it is now just the f mode, but obviously it uses the quadrature still. When you said that only the f mode would be enough, did you mean that it would not use the quadrature (A+B) at all? 

But for what was the issue, is seems that the servo power wires had just to be flipped. So, now all three axis have different wire orders.. But it only worked good with the right order in every axis.

I have not done proper pid tuning yet. I can jog the x axis in one way 12000mm/min (should get it 15000mm/min like original), but then the other way becomes joint follow error. Y axis little bit lower values. Z axis have not tried the max speed. Are these just pid issue or rotor angle needs ro be adjusted or something else?

So all axis work pretty much just as perfect they should. I can move the axis some random amount when the machine is off, then when i power it on and hit enable, all axis is pretty much spot on, not actual movement happening but the servo will be still. And Z-axis have worked perfectly too, just need to adjust the hal so that when power off the brake will go on before servo will lose its power (drops 0.3mm now). Not a single sserial error happened since I flipped all the wires in right order

Already milled a couple of pieces, looks to be already very precise when looking the axis actual values(0.001mm). Next step will be the proper pid tuning, and have to fiqure a way for getting spindle speed feedback from the fanuc drive. 

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.083 seconds
Powered by Kunena Forum