Brauche Hilfe bei Auswahl von Mesa Analogkarte und Bezugsquelle

More
19 Jul 2021 22:36 #215348 by PCW
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
19 Jul 2021 23:10 #215352 by tommylight
So, mach ein update und upgrade fur die LinuxCNC, es gibt version 2.8.2 beim Buildbot:
sudo apt-get update
sudo apt-get install LinuxCNC
im terminal.
Gruss,

Please Log in or Create an account to join the conversation.

More
20 Jul 2021 17:15 - 20 Jul 2021 17:15 #215426 by andrax
OK,

hab jetzt das Update auf die 2.8.2 gemacht.
Im Pncconf kann ich die Karte nicht Auswählen.
Ich hab das selbe Problem wie DoWerna.
Im Wizard hab ich jetzt die 7i92 genommen und kann ebenfalls die Num of PWM generators nicht hochstellen.
Ich werd noch mal die LiveCD in englisch booten und dann probieren.
Brauche ich evtl. die Version 2.9?

Gruß

Andre
Last edit: 20 Jul 2021 17:15 by andrax.

Please Log in or Create an account to join the conversation.

More
20 Jul 2021 17:36 #215427 by PCW
Es gibt keine pncconf-Unterstützung für das 7I97, wie ich bereits sagte, die 7I97-Firmware sollte aktualisiert werden und dann sollten die basic7i97 hal/ini-Dateien als Ausgangspunkt für . verwendet werden
Maschinenkonfiguration.

Please Log in or Create an account to join the conversation.

More
20 Jul 2021 17:58 #215428 by andrax
Alles klar, danke.

Werde so machen.

Gruß 

Andre

Please Log in or Create an account to join the conversation.

More
01 Aug 2021 08:48 #216586 by andrax
So, 7i97 läuft.
Habe jetzt erstmal zu Testzwecken die mitgelieferte testkonfig aktiviert und die Encoder von 2 Servos  dran gehängt.
Also Signale kommen rein aber auf dem Axisscreen zuckt die Position nur hin und her.
Scope zeigt nur A Phase an und bei B tut sich nichts(beide Encoder)
Duchgemessen, Signale kommen aber rein.
Irgend was stimmt da noch nicht oder er kommt mit der Encoderauflösung nicht klar. Es sind 17bit encoder und bringen 131072 Incremente je Umdrehung.

Gruß 

Andre

Please Log in or Create an account to join the conversation.

More
01 Aug 2021 14:09 #216602 by PCW
Klingt so, als ob die Encoder es nicht sind
Quadraturtyp

Please Log in or Create an account to join the conversation.

More
01 Aug 2021 18:50 #216642 by andrax
 Der Fehler saß wie üblich vor der Maschiene.
Ich hab die Anschlussreihenfolge nicht beachtet und A-Phase mit Z-Phase vertauscht, nu läufts.
Aber der Spaß geht weiter.
Für die Y-Achsen hab ich MRJ70A im Einsatz. Der Anschluss erfolgt über negative Logik (Sink Type).
Meine IO ist Ethercat (Source Type).
Da werden wohl einige Optokopler drauf gehen.

Gruß 
Andre
 

Please Log in or Create an account to join the conversation.

Time to create page: 0.088 seconds
Powered by Kunena Forum