Parallelport Pins keine Spannung

More
18 Feb 2022 07:42 #235215 by newcncsmith
Teste ich nachher mal was mit -vv angezeigt wird.

Was ist eigentlich der Unterschied zwischen "lspci -v" und "lspci -vv" ?

Von der Syntax im Terminal habe ich leider (noch) keinerlei Ahnung...

Wenn ich die Dateien in mein Verzeichnis kopiere müsste ptest ja als eine meiner Konfigurationen auftauchen, oder?

Wie auch immer, hat auch so funktioniert. Ich glaube meiner schwierigere Baustelle liegt gerade am Port selbst.

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 08:05 #235216 by spicer
In einem meiner genannten Links wäre auch etwas über den Tester: wiki.linuxcnc.org/cgi-bin/wiki.pl?Parallel_Port_Tester

Gib doch mal "man lspci" in der Konsole ein. Vllt ist da -vv beschrieben.

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 09:10 #235218 by newcncsmith
Teste ich nachher auch mal.

Meine Anfrage beim Importeur DeLock ergab, dass die Karte nicht für Linux freigegeben ist und daher keinen Support erhält.
Keine der DeLock Karten, die ich mir angesehen habe, hat eine Linus Freigabe.
Daher kann man wohl pauschal sagen, falls man DeLock Karten einsetzt, ist man auf sich allein gestellt.
Vermutlich liegts auch nicht an der fehlenden Freigabe sondern an fehlender Kompetenz. Ich glaube, die können nur verpacken.

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 09:12 - 18 Feb 2022 09:13 #235219 by newcncsmith
Den Link habe ich gesehen und genau gemacht, was da steht:
"To run this place both files in the same directory and open a terminal window and use the command

halrun -I -f ptest.hal"

Ich habe also auf dem "Schreibtisch" einen Ordner erstellt und die Dateien da hinein kopiert ...

Im Terminal muss man aber mit "cd" erstmal in diesen Ordner wechseln. Wie damals bei DOS ;-)
Last edit: 18 Feb 2022 09:13 by newcncsmith.

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 09:39 #235221 by spicer

Im Terminal muss man aber mit "cd" erstmal in diesen Ordner wechseln. Wie damals bei DOS ;-)
 


Das ist klar :D
dir zeigt Verzeichnisse und Dateien
cd .. geht 1 Verzeichnis zurück
sudo Nachfoldender Befehl mit root-Rechten ausführen

Die meisten Hersteller wissen nichts von Linux und schreiben desshalb auch nichts von Linuxkompatibilität.
Auch liefern sie keine Linux Treiber. Allerdings läuft die allermeiste Hardware ootb.
Bei top aktueller (neu erschienen) HW happert's aber manchmal.

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 15:27 #235237 by newcncsmith
lspci -vv:

03:00.2 Parallel controller: MosChip Semiconductor Technology Ltd. PCI 9865 Multi-I/O Controller (prog-if 03 [IEEE1284])
Subsystem: Device a000:2000
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 32, Cache Line Size: 64 bytes
Interrupt: pin C routed to IRQ 19
NUMA node: 0
Region 0: I/O ports at dd00
Region 1: I/O ports at dc00
Region 2: Memory at fdcfd000 (32-bit, non-prefetchable) [size=4K]
Region 4: Memory at fdcfc000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>
Kernel driver in use: parport_pc
Kernel modules: parport_pc

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 15:34 #235238 by spicer
Hast Du nun mal mit nur einer LPT Karte probiert?

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 15:58 - 18 Feb 2022 19:49 #235242 by newcncsmith
Bin gerade voll am probieren ...

Es ist ja eh nur eine Karte aber mit zwei Ports und jetzt kommts:

Ich hab auf Verdacht mal die Karte rausgezogen und drei-viermal wieder reingesteckt um eventuelle Kontaktprobleme auszuschließen.

Zwar ging ich nicht davon aus, weil die Karte ja erkannt wird, was auf gute Kontakte schließen lässt.

Trotzdem hat sich was geändert und zwar funktionieren jetzt die Pins 2-9 und geben knapp 3,3V aus bzw. zeigen HIGH an falls bestromt (mit einer Brücke).

Bloß Pins 1, 14, 16 und 17 geben nur 164mV aus und zwar an beiden Ports gleichermaßen.

Sollten die sich nicht verhalten wie alle anderen Pins auch?
Last edit: 18 Feb 2022 19:49 by newcncsmith. Reason: Falsche Pins angegeben

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 16:04 #235243 by spicer
Pin 1 ist der "STROBE". Keine Ahnung, wie der sich verhält. Ist wahrscheinlich ein pulsierendes Signal.
Das würde die halblebige Spannung erklären.

Please Log in or Create an account to join the conversation.

More
19 Feb 2022 20:55 - 19 Feb 2022 21:20 #235350 by newcncsmith
Ich habe heute mal eine andere Karte probiert und zwar eine 1xLPT PCI Karte und die scheint zu funktionieren.

Watchdod auf Pin16 kommt und Relais auf Pin1 kommt auch.

Zwar hat Pin1 5V und Pin2 nur 3,3V aber das ganz pingelige hab ich mir inzwischen abgewöhnt.

Soweit so gut...

Mein Mainboard hat aber nur einen PCI Slot also muss ich das vielleicht wechseln.
Last edit: 19 Feb 2022 21:20 by newcncsmith.

Please Log in or Create an account to join the conversation.

Time to create page: 0.112 seconds
Powered by Kunena Forum