Upgraded from 2.7 to 2.8 and GladeVCP is not working

More
03 Jun 2023 13:03 #272817 by LearningLinuxCNC
OK,

So I commented out the PostguiHAL lines that were attempting to connect to the missing pins. Launched Linuxcnc and took a look at HALshow to see what was going on.

Attached iis a screenshot showing that the pin in question does exist. It is only being netted in the postgui-hal file, Also attached. For reference you can also see my ,ini file attached.

Very puzzling.
Attachments:

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 13:23 - 03 Jun 2023 13:27 #272819 by LearningLinuxCNC
Furthermore. If run the netting commands connecting to the button copying and pasting the commented lines from the PostGUIhal file It works.

Un-comment the lines in the PostGUIhal file and it gives the error.
Attachments:
Last edit: 03 Jun 2023 13:27 by LearningLinuxCNC.

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 13:38 #272820 by LearningLinuxCNC
Seems a similar issue was raised on this thread.

forum.linuxcnc.org/gmoccapy/47803-custom...-cannot-load-postgui

According to one post the display calls the postgui.hal file, Gmoccapy is being used in both cases so something must have happened between 2.7 and 2.8 that causes Gmoccapy to call postgui.hal before the GladeVCP panels are fully loaded.

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 17:04 #272822 by HansU

Seems a similar issue was raised on this thread.

forum.linuxcnc.org/gmoccapy/47803-custom...-cannot-load-postgui

According to one post the display calls the postgui.hal file, Gmoccapy is being used in both cases so something must have happened between 2.7 and 2.8 that causes Gmoccapy to call postgui.hal before the GladeVCP panels are fully loaded.



What if you connect the pins in SBOHalCB4.hal instead of in the postgui hal file?
The following user(s) said Thank You: LearningLinuxCNC

Please Log in or Create an account to join the conversation.

More
03 Jun 2023 20:27 #272837 by LearningLinuxCNC
That was the fix.

Thank you sir.

Please Log in or Create an account to join the conversation.

More
04 Jun 2023 11:02 #272872 by HansU
Not for this one. You found the solution more or less by yourself

Please Log in or Create an account to join the conversation.

Moderators: mhaberlerHansU
Time to create page: 0.183 seconds
Powered by Kunena Forum