V70 stepperonline VFD not responding to RS485 USB not sure what left to try.

More
21 Jun 2022 15:52 #245544 by MrJRB
I've been attempting to communicate with my V70 series VFD from stepperonline via RS485 USB dongle with no luck whatsoever.
I've configured all the expected VFD settings as per it's manual here .

F001 : 2 - control via coms port
F002 : 2 -  frequency setting use coms port
F163 : 1 - modbus slave address 1
F164 : 1 - 9600 baud rate
F165 : 3 - 8 bit no parity 1 end for RTU
F169 : 0 - Use modbus instead of v70 protocol (was factory default despite manual stating otherwise)

Dongle link, wiring & VFD pinout photo: 

Dongle link

 

A to RS485+
B to RS485-
GND to GND

Tried swapping the A and B connections with no luck.

Attempted to connect via spindle talker 2 on windows with no luck either.

Screenshot of my vfd config in PnCConf:
 

I'm at an odds at this point given I think the dongle is fine given it shows up in windows device manager, PnCConf external controls and via terminal
lsusb
.
Seems I'm in the same situation as Jason on this forum .

What options do I have for troubleshooting RS485?
Terminal tests, multimeter testing the VFD's protocol ports?

I've tried a simple halrun test as well.
 
 
Attachments:

Please Log in or Create an account to join the conversation.

More
21 Jun 2022 19:13 #245547 by spumco
Suggest the following, in order...

#1 - check jumper J4; factory default is RS485 comms OFF.  See page 8 in manual.

#2 - As cheap as they are, try another dongle.  Just because it's showing up as a valid USB device doesn't mean it's working (i.e. output/input to the VFD).
The following user(s) said Thank You: MrJRB

Please Log in or Create an account to join the conversation.

More
21 Jun 2022 20:17 #245552 by MrJRB
#1

J4 is in the OFF position indeed so it's that's not the issue.

#2

I suppose I should, it's a shame given the amazon reviews had a user using it with a HuanYang VFD.
I'll buy another one from this supplier (given they worked for some) and another elsewhere then.

Please Log in or Create an account to join the conversation.

More
21 Jun 2022 20:59 #245556 by tommylight


#1 - check jumper J4; factory default is RS485 comms OFF.  See page 8 in manual.


Should it be ON ?
The following user(s) said Thank You: MrJRB

Please Log in or Create an account to join the conversation.

More
21 Jun 2022 22:30 #245560 by spumco
YES!

If the jumper is OFF, RS485 is OFF - at least that's my interpretation of the manual.

 
Attachments:
The following user(s) said Thank You: MrJRB

Please Log in or Create an account to join the conversation.

More
21 Jun 2022 22:50 - 21 Jun 2022 22:52 #245561 by MrJRB
I should've mentioned this earlier but I've tried with the jumper in both the ON and OFF positions to no avail, apologies.

I've ordered some more dongles now, will take a few days to arrive though.
Last edit: 21 Jun 2022 22:52 by MrJRB. Reason: Grammar fix.

Please Log in or Create an account to join the conversation.

More
22 Jun 2022 00:22 #245570 by tommylight


 
 

NO!
:)
That is for termination only, but still i would leave it ON, not OFF.
If there are more than two devices on the RS485 chain, then the two at the ends of the line should be terminated, the rest in between should not be terminated.
The following user(s) said Thank You: spumco

Please Log in or Create an account to join the conversation.

More
22 Jun 2022 00:48 #245573 by Hakan
Does the VFD actually work with the huan yang driver? I don't think it is real modbus.
Maybe try with the real modbus hal component.
The following user(s) said Thank You: MrJRB

Please Log in or Create an account to join the conversation.

More
22 Jun 2022 10:12 #245583 by MrJRB

Does the VFD actually work with the huan yang driver? I don't think it is real modbus.
Maybe try with the real modbus hal component.


Likely not in hindsight, I hadn't realised spindle talker was written only for huan yang vfds...
How would I go about utilising the real modbus component, what's it's name?

Please Log in or Create an account to join the conversation.

More
22 Jun 2022 14:28 - 22 Jun 2022 14:33 #245595 by MrJRB
Okay well I've discovered MB2HAL, have modified the example .ini to suit my VFD.
I've now managed to communicate with my VFD, so hurrah, it's not borked! 

This example here sets the setting F002 to 0, amusingly cutting off communication understandably.
[TRANSACTION_01]
MB_TX_CODE=fnct_04_read_input_registers
FIRST_ELEMENT=2
NELEMENTS=3
HAL_TX_NAME=XDrive02
MAX_UPDATE_RATE=10.0
DEBUG=1

Setting FIRST_ELEMENT was what defined which setting was changed, no idea what defines the value.
I was trying to set the frequency and in turn the value of the register address seen in the example below. (as I read that was what you set the first element to.)
 

So the question is, what do I do now?

I've attached my .ini file for reference.
 

File Attachment:

File Name: mb2hal_custom.ini
File Size:5 KB
Attachments:
Last edit: 22 Jun 2022 14:33 by MrJRB. Reason: Formatting.

Please Log in or Create an account to join the conversation.

Time to create page: 0.378 seconds
Powered by Kunena Forum