7i92 and G540 combination?

More
23 Apr 2023 07:21 #269671 by P.J.B.C
I should have asked in advance of ordering; but here i am....
I am currently in the process of finishing a long delayed pet project of finishing my desktop router/mill.
It has been a hassle trying to configure the pncconfig, I don't know what i am doing (stepconfig was a breeze).
The problem i am having is i can't seem to latch the charge pump...
I don't know if it is the correct pin, i am assigning because of the numbering system.. ( confusing!)
The question i am having is wether or not the mesa card can even accept the fixed pinouts of the g540...?
The numbering system of the pncconfig suggests that i can't, as the stepgen pin settings are pretty much already in place...
i was trying to get it going a year or two ago and gave up. The older release didn't even have a setting for the 7i92...
but now i ask; There is a g540x2 preconfig but is there any advantage in using it? i can seem to get my head around it...
Also; I'm hoping to use the second port with a basic BOB from peter homann Do you think that will work either...?
 
Here you can see the configuration i saw fit to construct. It is a 7i92h and so it just relies on 26pin IDC connectors and ribbon cables, I thought it would be brilliant because of the small footprint.
Attachments:

Please Log in or Create an account to join the conversation.

More
23 Apr 2023 14:24 - 23 Apr 2023 14:27 #269688 by PCW
Replied by PCW on topic 7i92 and G540 combination?
1. Yes, you would use the 7i92_g540x2 firmware for a G540
(this is necessary as it has the stepgens and PWMgen on the
correct pins for a G540 drive)

2. You need to write this firmware to the 7I92 card, something like:
mesaflash --device 7i92 --addr 10.10.10.10 --write 7i92_g540x2d.bit --reload

3. You can verify that the pinout is correct with:
mesaflash --device 7i92 --addr 10.10.10.10 --dbname1 g540 --readhmid

4. The Homann breakout can be used for GPIO with the 7i92_g540x2d.bit configuration
but to use any other features (like stepgens encoders or PWMgens) it would need specific
firmware
Last edit: 23 Apr 2023 14:27 by PCW.

Please Log in or Create an account to join the conversation.

More
26 Apr 2023 06:37 - 26 Apr 2023 06:38 #269949 by P.J.B.C
Replied by P.J.B.C on topic 7i92 and G540 combination?
Thank you so much for letting that to bare... I probably have been told before but i just doubted it...
I have forgotten where to download the mesaflash software; but it seems that i have a copy flashed already...
 --readhmid  gets a reponse;
 
which is fine, but i don't recognize the pinouts they aren't the last time i used pncconf, they look like the first time i used it...

So the question now becomes how do i set the pins..?
 
Attachments:
Last edit: 26 Apr 2023 06:38 by P.J.B.C.

Please Log in or Create an account to join the conversation.

More
26 Apr 2023 07:20 #269953 by P.J.B.C
Replied by P.J.B.C on topic 7i92 and G540 combination?
i just restarted the system and this came up which is similar to the current settings...
can you tell me if 016 on the pncconfig is the same as (pin16: chargepump)on the readhmid page?
 
 
Attachments:

Please Log in or Create an account to join the conversation.

More
26 Apr 2023 14:06 #269981 by PCW
Replied by PCW on topic 7i92 and G540 combination?
It looks like you did not select G540 firmware in pncconf
The chargepump is Stepgen 4 on DB25 pin 16 (as the --readhmid pinout  shows)

 

 
Attachments:

Please Log in or Create an account to join the conversation.

More
27 Apr 2023 05:21 #270031 by P.J.B.C
Replied by P.J.B.C on topic 7i92 and G540 combination?
currently i am trying to get the pncconf to make a change to the readhmid...
the number of step gens i have selected in pncconf is 5; while the readhmid still persistantly shows 10...
is there perhaps some sort of hard set that i have performed in an earlier session,
do you know of any way in which i could have opted for a hardset...?
I have a vauge memory of such a thing...

Please Log in or Create an account to join the conversation.

More
27 Apr 2023 09:31 #270049 by tommylight
Set stepgens to 4.
That will not change the results of readhmid as those are in the firmware.
Any stepgen or pwm or encoder pins not used in PncConf revert to being IO and cam be used as input or output.

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 04:06 #270160 by P.J.B.C
Replied by P.J.B.C on topic 7i92 and G540 combination?
so the the readhmid is set to the correct firmware, and shows the correct pins?
I think i need six stepgens there is the chargepump on both BOB's too...
are outputs and analog signals stepgens also?

what do you think i should do next...
I still blind as to why the CP won't latch...

 

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 05:11 #270167 by PCW
Replied by PCW on topic 7i92 and G540 combination?
Did you setup stepgen4 as a chargepump stepgen?
(as shown in my pncconf screen shot)

A G540 need 4 stepgens for motion, the fifth stepgen (stepgen 4) is used
for driving the chargepump

This means you only need 5 stepgens unless you need more for motion
or charegpump on the second connector.

Note that if the second connector has a different pinout than the G540
(and not just GPIO) you may need different firmware

Please Log in or Create an account to join the conversation.

More
01 May 2023 04:10 - 01 May 2023 04:16 #270377 by P.J.B.C
Replied by P.J.B.C on topic 7i92 and G540 combination?
I have been having trouble logging in(the system locks me out every other time I log-in), hence the delay between posts...sorry.
Yes i now understand that the sixth pin from the top is the pin 16 and that it should be set to charge pump.
It wasn't until i started this thread that i learnt it though(the numbering system was a hurdle i hadn't figured out).
So, what has been happening was i could see, after setting the pin correctly,
was that the fault light would latch on for half a second and latch back.
I thought this was odd so i disabled the charge pump on the g540,
and found i needed to invert the signal to the fault input on pin 15.
This got me some motor movement, and i set the charge pump back to on.
But with the charge-pump re-enabled i got different behaviour.
The f1 key is now fully locked and won't operate.

I get a lot of errors about read and write queue's
and one about a 'something' has "bit" and that i should set a 'setting' to false.

I noticed there is a charge pump setting for both step gen and output,
I have tried both inverted and normal...
 
Last edit: 01 May 2023 04:16 by P.J.B.C.

Please Log in or Create an account to join the conversation.

Time to create page: 0.339 seconds
Powered by Kunena Forum