Home Index 7i96s can't detect Signal

More
31 Jan 2024 14:52 #292069 by PCW
Yes, there's an error in the manual. I will fix that

W1 Index mode
W2 B mode
W3 A mode

What I suggested was that you disconnect your encoder completely
(unplug the connector at the 7I96S), set the index input to single
ended mode (W1 LEFT) And then monitor the index signal with halshow
and see if its state changes when you ground the INDEX+ pin (TB2 pin 13)

If the hal pin does not change, there is a fault in the 7I96S

Please Log in or Create an account to join the conversation.

More
02 Feb 2024 09:10 #292200 by abdulasis12

Yes, there's an error in the manual. I will fix that

W1 Index mode
W2 B mode
W3 A mode

What I suggested was that you disconnect your encoder completely
(unplug the connector at the 7I96S), set the index input to single
ended mode (W1 LEFT) And then monitor the index signal with halshow
and see if its state changes when you ground the INDEX+ pin (TB2 pin 13)

If the hal pin does not change, there is a fault in the 7I96S

see if its state changes when you ground the INDEX+ pin

Sorry, I'm give you confirm
You mean after disconnect Encoder ,then TB2 pin 13 connect to TB2 pin 15 right(GND , ground) ?  and monitor .

 
Attachments:

Please Log in or Create an account to join the conversation.

More
02 Feb 2024 09:30 - 02 Feb 2024 09:31 #292201 by tommylight

You mean after disconnect Encoder ,then TB2 pin 13 connect to TB2 pin 15 right(GND , ground) ? and monitor .

Yes.
Last edit: 02 Feb 2024 09:31 by tommylight.
The following user(s) said Thank You: abdulasis12

Please Log in or Create an account to join the conversation.

More
02 Feb 2024 09:56 #292207 by abdulasis12

You mean after disconnect Encoder ,then TB2 pin 13 connect to TB2 pin 15 right(GND , ground) ? and monitor .

Yes.

Okay, I open removed all wire terminal encoder and screw yellow wire to Pin9(GND)  and I trig to Pin 13(IDX+).

I open linuxcnc and start control , and not do anything on software only Open hallshow.
My friend behind machine and trig wire to Pin13

Result
On hall show Not any change when my friend connect and disconnect wire  from Pin 9 (GND) and Pin13(IDX+)

 

 
Attachments:

Please Log in or Create an account to join the conversation.

More
02 Feb 2024 10:02 #292209 by tommylight
You need to monitor the
encoder.0.index
Or similar.
Sorry, on the phone so can not find exact pin name.

Please Log in or Create an account to join the conversation.

More
02 Feb 2024 15:57 #292225 by PCW
You need to watch:

hm2_7i96s.0.encoder.00.input-index
 
The following user(s) said Thank You: abdulasis12

Please Log in or Create an account to join the conversation.

More
03 Feb 2024 01:38 #292268 by abdulasis12
Good morning MR.PCW , Tommylight
this result : No any change on index  (when wire connect and disconnect pin9 to pin13) 
IC have a problem ??
 
Attachments:

Please Log in or Create an account to join the conversation.

More
03 Feb 2024 03:22 #292273 by PCW
Note: You must tighten the screws if you are touching the screw
and expecting it to connect to the input pin.

(I would have just unplugged the connector rather than disconnecting the wires)

If you still don't get the hal pin to change, its likely the 26LS32 RS-422
receiver  chip is damaged or there is some other fault on the card.

If this is the case, we can send a new card (I would request the card
back for analysis but I expect base on your time zone that
shipping costs both ways would be prohibitive.)
 
The following user(s) said Thank You: abdulasis12

Please Log in or Create an account to join the conversation.

More
03 Feb 2024 08:47 #292285 by abdulasis12
Hi MR.PCW
I have some update after analyze from you.
I have 1 more 7i96s  REV.C  from my milling machine I try swap board to my lathe and mesaflash for same old board.
I reconnect all terminal back and change jumper back to default (differential type).
I try Home X , Yes now can Home (DRO show green color and X axis motor stop).
Thank you for help me analyze.

I ever bought 26ls32 IC from China but I Can't find it , maybe if I found it on  next week  I will try to replace and update you again .
If sent back to you for renew board I think not good for me about shipping cost.
Thank you again bro.

Asis,

 

 
 
Attachments:
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
08 Feb 2024 05:28 #292821 by abdulasis12
Hi PCW , Tommylight

Update
I Replace, Now Index signal work !!

Thank you for advice.
Asis,

 
 
 
Attachments:
The following user(s) said Thank You: tommylight, besriworld

Please Log in or Create an account to join the conversation.

Time to create page: 0.414 seconds
Powered by Kunena Forum