Installing troubles Rasberry Pi 4 model B 4 GB

More
30 Aug 2023 07:32 #279347 by Jeffy
I have a Rasberry Pi 4 model B 4 GB and a Mesa 7I96S. I am trying to install linuxCNC but having some issues. I am using the Raspberry Pi imager V1.7.5 and I have tried each of these configurations (and a couple of different ISO's I found) on both a 16 and 128-GB SD card

When I try to install LinuxCNC 2.8.4 Debian 10 Buster PREEMPT-RT I get the following screen

 


When I try to install LinuxCNC 2.8.1 Raspberry Pi OS based on Debian 10 Buster I get the following screen saying that the software is too old.

 

I can't figure out why it won't install. Sorry if this issue has been answered somewhere else, I didn't find any threads with the same issue, Any help would be much appreciated.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 07:52 #279350 by cornholio
What exact images are you using ?

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 13:06 #279374 by rodw
there is an option in the imager to update the bootloader. It shows that is required. on a sucessful burn, the screen goes green. Try that and see if it helps. I was able to build an image from scratch and built linuxcnc on the pi this week. I needed to update the boot loader. I've recorded the required steps to install linuxcnc so the next step is to script that inside the installer which runs on a X86 machine and crosscompiles.

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 16:16 #279389 by Jeffy

there is an option in the imager to update the bootloader.
 

Where? I do not see in settings

rodw post=279374 userid=20660I've recorded the required steps to install linuxcnc so the next step is to script that inside the installer which runs on a X86 machine and crosscompiles.

Where is this?

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 16:17 #279390 by Jeffy

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 17:23 #279399 by tommylight
Changed the tittle to reflect it's for RPI 4.

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 20:38 #279414 by rodw

there is an option in the imager to update the bootloader.
 
Where? I do not see in settings

rodw post=279374 userid=20660I've recorded the required steps to install linuxcnc so the next step is to script that inside the installer which runs on a X86 machine and crosscompiles.

Where is this?

1. Keep looking at the dropdowns or use google 
2. It isnt anywhere public yet.

Please Log in or Create an account to join the conversation.

More
31 Aug 2023 01:56 #279430 by Jeffy
Yeah guys I'm really stuck here

Please Log in or Create an account to join the conversation.

More
31 Aug 2023 02:18 #279433 by rodw
The best advice would be to use the method described in the V 2.9 getting started docs. 
But the version of linuxcnc is fairly old and spi I don't think is supported.
Once I have something working, I will share an image ready to go. Hopefully one more build away....
 

Please Log in or Create an account to join the conversation.

More
20 Oct 2023 16:05 - 20 Oct 2023 16:06 #283359 by vossie001
Hi Jeffy,

Did you manage to figure out how to get it working?
This morning i also got my raspberry PI4B 4GB + Mesa 7i96S delivered and when trying to install get same error:
start4.elf: is not compatible
This board required newer software.

i downloaded from linuxcnc.org/downloads/ LinuxCNC 2.8.1 Raspberry Pi OS based on Debian 10 Buster and used Raspberry Pi Imager V1.7.5 to write image to card.

writing the stock images selected on the pi imager, the PI boots up ok but when loading the "Pi OS based on Debian 10 Buster" "2021-01-20-linuxcnc-pi4.img" file get error .
Last edit: 20 Oct 2023 16:06 by vossie001.

Please Log in or Create an account to join the conversation.

Time to create page: 0.223 seconds
Powered by Kunena Forum