Startup trouble

More
04 Nov 2023 21:55 #284572 by poesel
Replied by poesel on topic Startup trouble
So electrically I would take 5V from TB1, route it through TB3 14 & 13 (OUT0+/-) to EN+ on the TB6600 and back from EN- to GND on TB1.
How do I get the Mesa card to switch OUT0 when I move an axis?
And is this worth the effort or just something you live with (with those drivers)?

Please Log in or Create an account to join the conversation.

More
04 Nov 2023 22:55 #284577 by PCW
Replied by PCW on topic Startup trouble
Yes, you could do it that way, typically you would enable the drives
with something like motion.motion-enabled

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 21:17 #284664 by poesel
Replied by poesel on topic Startup trouble
I guess I'll have to read some more docs until I understand what I have to do for the enable.

The step pulse of 40000 is not a problem?
I need about 80 steps per mm and 33 mm/s max speed. That is from the old grbl config so that should already include the microsteps.
80 x 33 = 2640 steps / s => 378 µsec max time per pulse. If the step pulse setting is at 40000 that's 40 µsec so I should be good, right?

Please Log in or Create an account to join the conversation.

More
05 Nov 2023 23:52 #284672 by PCW
Replied by PCW on topic Startup trouble
Yes, that should be fine even with step length and step space = 40000
The following user(s) said Thank You: poesel

Please Log in or Create an account to join the conversation.

Time to create page: 0.184 seconds
Powered by Kunena Forum