Ethercat installation from repositories - how to step by step

More
16 Feb 2024 09:07 #293485 by rodw
Please go back to the first post and ensure you have followed every step.
It appears you missed this one
To ensure the ethercat port has permissions on startup. Create a udev rule
The following user(s) said Thank You: jjdege

Please Log in or Create an account to join the conversation.

More
16 Feb 2024 09:56 - 16 Feb 2024 09:58 #293489 by jjdege
hi rodw
I had already given the permissions and everything had been working for some time
it happened after "apt upgrade"
now I gave them again, but nothing, if I start ethercat it gives me this:

 

Thank you

 
Attachments:
Last edit: 16 Feb 2024 09:58 by jjdege.

Please Log in or Create an account to join the conversation.

More
16 Feb 2024 10:15 #293494 by rodw
This is a different error so something has changed.
Its saying ec_master cannot be found but the full line is cut off.
If you have built from source, the location is different to using the repositories.
I would do this and go through the instructions in the first post exactly to reinstallsudo apt remove ethercat-master libethercat-dev  linuxcnc-ethercat
sudo apt install ethercat-master libethercat-dev  linuxcnc-ethercat

Please Log in or Create an account to join the conversation.

More
16 Feb 2024 10:57 #293498 by jjdege
yes rodw
I had already done what you wrote
I did it again and it doesn't change
with sudo systemctl start ethercat.service
from error

 

but I only upgraded
Thank you
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Feb 2024 16:56 #293525 by jjdege
Hi rodw
I solved it by going back to linux-image-6.1.0-17-rt-amd64

sudo apt remove ethercat-master libethercat-dev linuxcnc-ethercat
sudo apt install ethercat-master libethercat-dev linuxcnc-ethercat

work!

I install linux-image-6.1.0-18-rt-amd64 still error
I don't know, maybe the work of recent times
Thank you
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

More
16 Feb 2024 17:39 #293531 by rodw
Great you got there in the end. A week ago I did an upgrade and got 6.1.0.17 so 6.1.0.18 is very new. Perhaps its not supported by the ethercat master.

Please Log in or Create an account to join the conversation.

More
17 Feb 2024 22:16 - 17 Feb 2024 23:03 #293660 by igh-vh
Have you tried
sudo dpkg-reconfigure ethercat-dkms
to rebuild the ethercat modules after upgrading the kernel? And are the corresponding headers also installed (linux-headers-6.1.0-18-rt-amd64)?
Last edit: 17 Feb 2024 23:03 by igh-vh.
The following user(s) said Thank You: rodw, jjdege, zmrdko

Please Log in or Create an account to join the conversation.

More
25 Feb 2024 17:29 #294411 by Rojs0nik
Hello everyone,

Can anybody help me because when I type
cd ~/dev
it says that there is no such file or directory

 
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Feb 2024 19:12 #294432 by rodw
Sorry, I missed a command
mkdir ~/dev
I amnot sure where scott is with his cia402 support as this may become redundant.

Please Log in or Create an account to join the conversation.

More
25 Feb 2024 19:31 #294435 by Rojs0nik
Thank you,

everything worked, now i can move on 

Please Log in or Create an account to join the conversation.

Time to create page: 0.156 seconds
Powered by Kunena Forum