Any recommendations for a mini PC for an EtherCAT setup?

More
21 Nov 2022 23:03 #257269 by mwc
Plain Bullseye has just installed without any major issues.

While it's fresh in my mind, this is what I've tried so far-
The 2.8.4 iso did run through the installer first time, with the only issue being it wouldn't detect any network ports. And as I don't have an already running linux system to compile the drivers, I figured I could deal with that later.
However the H3+ wouldn't boot from the nvme drive. I still had the various security boot options active, so I deactivated them, and tried another install letting the installer re-partition theSSD, but it failed when trying to install grub.

There is a known issue with the H3 and nvme drives, so I updated the firmware, and tried another install, but again no network, and it failed trying to install grub.

At this point I thought it was possibly something to do with the partition table having already been written, so I tried to boot into the Live distribution, but it would never load as per my previous post.
Even trying the recovery/safe mode, the system would just hang and not even get as far as normal live mode did.

I even tried installing onto another usb stick, but grub failed to install.

Your bullseye build has just finished downloading, so I'll try that when I get home from work tomorrow.

Please Log in or Create an account to join the conversation.

More
22 Nov 2022 21:00 #257377 by mwc
Grotius, I've just tried your iso, however when booting, I get the following messages/errors-

Booting Debian GNU/Linux'
error: no such device: a01d1a40-2019-42a9-8048-cb5ec1418ea1. Loading Linux 5.10.0-4-rt-amd64 error: file /boot/vmlinuz-5.10.0-4-rt-amd64' not found. Loading initial ramdisk error: you need to load the kernel first.
Press any key to continue...
Failed to boot both default and fallback entries. Press any key to continue....

Any ideas?

Please Log in or Create an account to join the conversation.

More
22 Nov 2022 21:01 #257378 by rodw
The 2,5gb NIC driver on the H3 was not introduced into the Linux kernel until V 5.9 so its first supported in Bullseye.
You can use Buster but you need to install the driver via the realtek web site. Please refer to notes  on the hardkernel site and forum.

In any case, once you get up and running with or without network  I'm going to say it is mandatory to install the realtek driver which is reported to give 15-30% improvement on their forum.. ANd also c]confirmed by another user solves the error finishing read  issue with mesa ethernet cards.

I've only installed onto the emmc drives from Hardkernel and had no issues.

Please Log in or Create an account to join the conversation.

More
22 Nov 2022 21:12 #257379 by rodw
If you said Bullseye installed, I would install Bookworm from debian's weekly builds, install linuxcnc from the included debs and install ethercat as per my forum sticky. With ethercat, I don't think you'll be affected by NIC latency. I don't think I built the realtek driver on my H2 ethercat machine. I think the etherlabmaster handles the NIC comms better than Mesa.

Please Log in or Create an account to join the conversation.

More
23 Nov 2022 00:15 #257410 by mwc
Latest update is I had to re-install bullseye after I done something blatantly stupid that made it unrecoverable.

I've now got as far as having updated to bookworm, which has solved a couple issues I had with Bullseye, which turned out to be that I had installed the non non-free-firmware version.
I'll now hopefully get LinuxCNC installed tomorrow, along with the ethercat stuff.

My first ethercat module should hopefully arrive tomorrow, otherwise it'll probably be next week due to an impending strike.
And the ethercat stepper driver kits I'd ordered are now ready for dispatch from China, so I should hopefully have all the bits needed to test a complete system by the end of next week.

Please Log in or Create an account to join the conversation.

More
23 Nov 2022 07:36 #257435 by rodw
You should be able to add the non-free to sources.list
linuxhint.com/enable-non-free-packages-d...0from%20repositories.

This is the bookworm iso I use
cdimage.debian.org/cdimage/unofficial/no...builds/amd64/iso-cd/

If you are going to be using Rtelligent drives, I have a config here which will gie you a start.
github.com/rodw-au/linuxcnc-cia402

Please Log in or Create an account to join the conversation.

More
23 Nov 2022 19:05 #257500 by mwc
And it works.
Worked my way through the instructions, and I now have bookworm with LinuxCNC installed with ethercat, and the Berkhoff module that got delivered today shows up in the ethercat slave list.
Although I can't yet test it, as I've only got encoder modules, and don't currently have any spare encoders to test it.

Stepper drivers are scheduled for delivery on Monday, so I'll just have to familiarise myself with LinuxCNC for now.
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

More
23 Nov 2022 19:45 - 23 Nov 2022 20:47 #257502 by mwc
Argh!

I can't get LinuxCNC to load any of the sim options.
I get the following error -

Print file information:
RUN_IN_PLACE=no
LINUXCNC_DIR=
LINUXCNC_BIN_DIR=/usr/bin
LINUXCNC_TCL_DIR=/usr/lib/tcltk/linuxcnc
LINUXCNC_SCRIPT_DIR=
LINUXCNC_RTLIB_DIR=/usr/lib/linuxcnc/modules
LINUXCNC_CONFIG_DIR=
LINUXCNC_LANG_DIR=/usr/lib/tcltk/linuxcnc/msgs
INIVAR=inivar
HALCMD=halcmd
LINUXCNC_EMCSH=/usr/bin/wish8.6
LINUXCNC - 2.9.0~pre0+git20221105.ffb6bda926
Machine configuration directory is '/home/moray/linuxcnc/configs/sim.axis'
Machine configuration file is 'axis.ini'
INIFILE=/home/moray/linuxcnc/configs/sim.axis/axis.ini
VERSION=1.1
PARAMETER_FILE=sim.var
TPMOD=
HOMEMOD=
TASK=milltask
HALUI=halui
DISPLAY=axis
COORDINATES=X Y Z
KINEMATICS=trivkins
Starting LinuxCNC...
Starting LinuxCNC server program: linuxcncsvr
Loading Real Time OS, RTAPI, and HAL_LIB modules
Starting LinuxCNC IO program: io
Starting HAL User Interface program: halui
linuxcnc TPMOD=tpmod HOMEMOD=homemod EMCMOT=motmod
Found file(lib): /usr/share/linuxcnc/hallib/core_sim.hal
Found file(lib): /usr/share/linuxcnc/hallib/sim_spindle_encoder.hal
Found file(lib): /usr/share/linuxcnc/hallib/axis_manualtoolchange.hal
Found file(lib): /usr/share/linuxcnc/hallib/simulated_home.hal
Found file(lib): /usr/share/linuxcnc/hallib/check_xyz_constraints.hal
Starting TASK program: milltask
Starting DISPLAY program: axis
Shutting down and cleaning up LinuxCNC...
task: 678 cycles, min=0.000007, max=0.009878, avg=0.001102, 0 latency excursions (> 10x expected cycle time of 0.001000s)
Removing HAL_LIB, RTAPI, and Real Time OS modules
Removing NML shared memory segments

Debug file information:
Note: Using POSIX realtime
Traceback (most recent call last):
  File "/usr/bin/axis", line 26, in <module>
    from OpenGL.GLUT import *
  File "/usr/lib/python3/dist-packages/OpenGL/GLUT/__init__.py", line 5, in <module>
    from OpenGL.GLUT.fonts import *
  File "/usr/lib/python3/dist-packages/OpenGL/GLUT/fonts.py", line 20, in <module>
    p = platform.getGLUTFontPointer( name )
  File "/usr/lib/python3/dist-packages/OpenGL/platform/baseplatform.py", line 350, in getGLUTFontPointer
    raise NotImplementedError(
NotImplementedError: Platform does not define a GLUT font retrieval function
2998
3052
Stopping realtime threads
Unloading hal components
Note: Using POSIX realtime

 Is this a generic LinuxCNC issue, or something to do with the ethercat bits being installed?
Unfortunately I never tried actually running LinuxCNC before installing all the ethercat bits

Edit-
It looks like some kind of issue with Python 3.10 which is the default in Bookworm, as tklinuxcnc screen loads, which from what I gather is the only sim screen that doesn't use python
Last edit: 23 Nov 2022 20:47 by mwc.

Please Log in or Create an account to join the conversation.

More
23 Nov 2022 21:29 #257515 by mwc
Since this appears to be unrelated to ethercat, I've started a new thread - forum.linuxcnc.org/9-installing-linuxcnc...n-issues-on-bookworm

Please Log in or Create an account to join the conversation.

More
23 Nov 2022 21:31 #257516 by tommylight
It is complaining about some GLUT font deep into Python folders.
Never seen that before.

Please Log in or Create an account to join the conversation.

Time to create page: 0.295 seconds
Powered by Kunena Forum