Ignore Limits option grayed out

More
24 Oct 2019 15:52 #148709 by Aciera
My mill uses compressed air to compensate the weight of the z-axis. After shutdown the Z-axis sits on the Limit-Home switch an I used to check the "Ignore Limits" in the jogging screen to move the axis off the switch. Now for some reason (and after quite a bit of changing other stuff in the HAL and INI) I can't check the box as it is grayed out.
Is there a setting somewhere concerning the "Ignore Limits" checkbox being active or not?

Thanks

Please Log in or Create an account to join the conversation.

More
24 Oct 2019 17:28 #148717 by pl7i92
you need to hit F2 or get the mashine restartet to get this option visible

Please Log in or Create an account to join the conversation.

More
25 Oct 2019 10:46 #148785 by Aciera
Thanks for your reply.
When I try to start the machine with F2 there is a message saying the machine cannot be started because an end switch is active. I'll try to get a screen shot next time I'm in the shop.

Please Log in or Create an account to join the conversation.

More
25 Oct 2019 11:31 - 25 Oct 2019 11:36 #148786 by Aciera
So here we are:
The machine sits on the Z-Limit/Home switch and I cant start the machine (F2). The errors are:
"Error: Joint 2 on limit switch"
"ERROR: Can't start machine. Is there a limit switch active?"

So I have to change the HAL and set the display to "axis", comment out the gmoccapy-postgui.hal and restart LinuxCNC with axis screen and I can check the "Ignore Limits" checkbox and move the axis oft the limit switch.
Why is this not possible in my gmoccapy? This used to work (I think).
Warning: Spoiler!
Attachments:
Last edit: 25 Oct 2019 11:36 by Aciera.

Please Log in or Create an account to join the conversation.

More
26 Oct 2019 08:45 #148818 by Aciera
Solved.
In gmoccapy as opposed to axis I have to go into E-Stop an out again for the "Ignore Limits" checkbox to become available.

Please Log in or Create an account to join the conversation.

More
29 Oct 2019 15:47 #149056 by andypugh
My mill does this, but I don't have this problem.

I think that if you activate "HOME_IGNORE_LIMITS" on the INI then the problem might go away.
(Though thinking further, it shouldn't. I will try to look in more detail at the behaviour of my machine this evening)

Please Log in or Create an account to join the conversation.

More
30 Oct 2019 12:07 #149155 by newbynobi
@Aceira,

what release of gmoccapy do you use? See title bar or setting page.
In 3.0.8 I do not have that Behavior.

Norbert

Please Log in or Create an account to join the conversation.

More
30 Oct 2019 18:52 #149202 by Aciera
Thanks Norbert for your reply. I'm still on 1.5.9!
So I guess I'll see about updating...

Thanks

Please Log in or Create an account to join the conversation.

More
31 Oct 2019 22:11 #149313 by newbynobi
I will check on 1.5.9

Norbert

Please Log in or Create an account to join the conversation.

More
02 Nov 2019 09:00 #149417 by rodw
I'm not sure if this would work, but I wonder if you could and2 the limit switch with the is-homing signal for that axis? That would allow you to jog off the switch before you home. That might not be quite the right signal but it might be worth exploring options like this might yield a solution.

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.134 seconds
Powered by Kunena Forum