LCNC 2.8 - Language bugs

More
22 Jun 2022 18:14 #245609 by zz912
I am trying translate Gmoccapy LCNC 2.8.8 to Czech language.
 
A lot of texts works, but home all axis not.
 
The problem is not only for my translate. DE translate have same problem.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
23 Jun 2022 18:37 - 23 Jun 2022 18:38 #245712 by HansU
It seems that you are not yet using Weblate for your translation.
You just have to add your language here hosted.weblate.org/projects/linuxcnc/gmocappy/.
Then I would strongly recommend you to do your translations there if you want to have them in master.
If you have already worked a lot on your translation based on the po file - I think there is a way to get your translations into Weblate.

Regarding the primary problem - I'll have a look...
Last edit: 23 Jun 2022 18:38 by HansU.

Please Log in or Create an account to join the conversation.

More
24 Jun 2022 14:51 #245791 by HansU
I fixed the strings in 2.8 as well as in master.

Please Log in or Create an account to join the conversation.

More
29 Jun 2022 08:35 #246141 by zz912

It seems that you are not yet using Weblate for your translation.
You just have to add your language here hosted.weblate.org/projects/linuxcnc/gmocappy/.
Then I would strongly recommend you to do your translations there if you want to have them in master.
If you have already worked a lot on your translation based on the po file - I think there is a way to get your translations into Weblate.
 

I am a very conservative person, so I will use version 2.8 for as long as possible.

If I created Czech for LCNC, will it be possible to easily switch LCNC to English in version 2.9? I am currently compiling the whole LCNC using "make" and I have a RIP installation, most LCNC users use live distribution and here I do not know how to change the language and whether it is possible at all. Czech is interesting only for some individuals, others would like to kill me if suddenly a change came and they had everything in Czech instead of English.

I also have a problem that I am not a machinist and I do not know suitable translations for some expressions. In addition, I find that Gmoccapy has features that I don't know what they are for, let alone how I translate their controls.

I tried to start a translation thread on the Czech forum
forum.strojirenstvi.cz/viewtopic.php?t=41960
but no one interested this topic. Maybe someone will be in the future.

Please Log in or Create an account to join the conversation.

More
29 Jun 2022 09:19 #246142 by zz912

I fixed the strings in 2.8 as well as in master.

Is there a way to get this fix?

I use RIP Installation. I download source from github:
 

I don't know the difference between "Branches" and "Tags"
 
Is "2.8" future version 2.8.3 in this moment?
Is in "2.8" this fix? 
Attachments:

Please Log in or Create an account to join the conversation.

More
29 Jun 2022 19:15 #246190 by zz912
I tried compile version 2.8 and it works. Thank you for FIX.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
29 Jun 2022 20:36 - 07 Jul 2022 19:55 #246203 by zz912
I found next bug:
Gmoccapy.py
line 1160
old: btn.set_property("tooltip-text", _("Press to jog axis {0}".format(axis)))
new: btn.set_property("tooltip-text", _("Press to jog axis {0}").format(axis))

line 1179
btn.set_property("tooltip-text", _("Press to jog joint {0}".format(joint)))
same problem

line 1229
btn.set_property("tooltip-text", _("Press to run macro {0}".format(name)))
same problem


I fixed it like you. Can I ask you for fix it in Github?

Edit: I made Pull request
github.com/LinuxCNC/linuxcnc/commit/cc1b...ff0bde4ffd9568313549
Last edit: 07 Jul 2022 19:55 by zz912.

Please Log in or Create an account to join the conversation.

More
03 Jul 2022 13:46 - 03 Jul 2022 14:16 #246506 by zz912
I probably found another bug related to the translation. I don't want to start another thread.
 
Attachments:
Last edit: 03 Jul 2022 14:16 by zz912.

Please Log in or Create an account to join the conversation.

More
03 Jul 2022 14:20 #246507 by zz912
I don't know if it's a bug, but it's strange that I'm being asked to translate text with underscores.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
03 Jul 2022 15:07 #246511 by zz912
I didn't find a way to translate the "command" label.
 
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.419 seconds
Powered by Kunena Forum