M66 doesn't work

More
17 Jul 2020 14:12 #174945 by Duongtantai8624
Replied by Duongtantai8624 on topic M66 doesn't work
My setup is a little bit weird cause im in third wolrd country so i have to stick with third world solution

This is pci e motion control card


This is linuxcnc bob


I use mach 3 board + relay board for io pin


Here's the loadrt line, but it no hm2 ::pinch:


I dont know how to open halmeter, i will figure out how to do it later but this is io port list show in operator_login
Attachments:

Please Log in or Create an account to join the conversation.

More
17 Jul 2020 15:15 #174948 by andypugh
Replied by andypugh on topic M66 doesn't work
That seems to be a clone of a 5i25. So there is no real guarantee that the dmesg output that tells you that GPIO 32 is on DB25 pin 12 is correct.

Can you use Halshow with PathPilot? That would let you check which physical input (if any) triggers when you toggle the physical input.
The following user(s) said Thank You: Duongtantai8624

Please Log in or Create an account to join the conversation.

More
17 Jul 2020 18:13 #174950 by tommylight
Replied by tommylight on topic M66 doesn't work

That seems to be a clone of a 5i25.

From Vietnam, of all places, and this is the second time i am seeing them on the web.
Back on subject, he did mention he is using USB something for inputs, so in that case i am not sure it will work.

Please Log in or Create an account to join the conversation.

More
18 Jul 2020 01:45 #174993 by Duongtantai8624
Replied by Duongtantai8624 on topic M66 doesn't work
You're right, this board is in vietnam.
About usbio inputs i mention in the subject, i mean when i check the port by hand it's work
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Jul 2020 01:48 - 18 Jul 2020 15:12 #174994 by Duongtantai8624
Replied by Duongtantai8624 on topic M66 doesn't work
This is my halmeter
Signals






Pins 32
Attachments:
Last edit: 18 Jul 2020 15:12 by Duongtantai8624.

Please Log in or Create an account to join the conversation.

More
18 Jul 2020 02:34 - 18 Jul 2020 02:41 #175001 by Duongtantai8624
Replied by Duongtantai8624 on topic M66 doesn't work
My halscope seems like everything work's fine

<iframe width="560" height="315" src="
" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen>
Last edit: 18 Jul 2020 02:41 by Duongtantai8624.

Please Log in or Create an account to join the conversation.

More
18 Jul 2020 03:59 - 18 Jul 2020 04:02 #175010 by Duongtantai8624
Replied by Duongtantai8624 on topic M66 doesn't work
I think almost found it, thanks for the halmeter, its very helpful
M66 code in my ini file wasn't turn on


I dont understand M64 wasn't turn on too but it's still function, my m66 still doesn't work and here's the error in status tab
Attachments:
Last edit: 18 Jul 2020 04:02 by Duongtantai8624.

Please Log in or Create an account to join the conversation.

More
19 Jul 2020 05:27 - 19 Jul 2020 05:28 #175111 by Duongtantai8624
Replied by Duongtantai8624 on topic M66 doesn't work
Problem is solved
I update pathpilot from virgin version to ver 2.0.1 and M66 is fixed
I found out it in tormach updates release notes ver 2.0.1
The file is not recognized is invoved with M66, i just spend 3 days for nothing :( :( :( :(

Attachments:
Last edit: 19 Jul 2020 05:28 by Duongtantai8624.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
19 Jul 2020 08:11 #175123 by tommylight
Replied by tommylight on topic M66 doesn't work
Thanks for reporting back with the solution.

Please Log in or Create an account to join the conversation.

More
19 Jul 2020 14:36 #175150 by snowgoer540
Replied by snowgoer540 on topic M66 doesn't work

Problem is solved
I update pathpilot from virgin version to ver 2.0.1 and M66 is fixed
I found out it in tormach updates release notes ver 2.0.1
The file is not recognized is invoved with M66, i just spend 3 days for nothing :( :( :( :(


Might as well go to the latest. They have fixed lots of errors since then.

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 1.498 seconds
Powered by Kunena Forum