THC always hits THC Velocity Lock

More
28 Feb 2021 01:44 #200362 by kramerda
Plasmac cutting beautiful parts - but THC just keeps dropping out due to Velocity Lock as cutting begins.
Running Mesa 7i76e w/THCAD-10, Linuxcnc version 2.8, Axis - see screen shot of Config and .ini Attached. Tried lots of variations of Voltage threshold and VAD Threshold - no luck. ARC Voltage reading about 80 volts with 'Use Auto Volts' during cutting. Read lots of forum posts thinking maybe Max Velocity or Max Acceleration not correct in .ini ????? All feedback much appreciated.
Dennis
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Feb 2021 02:51 #200367 by rodw
What cut velocity are you trying to cut at?
Your ini file seems to have very low max velocities (1500mm/min)
This could be below your cut velocity so your machine never gets to cut speed.
eg. I cut 2mm steel at 2219 mm/min
VAD might never get enabled.

Please Log in or Create an account to join the conversation.

More
28 Feb 2021 03:05 #200368 by kramerda
thanks for quick reply - these THC tests were run on 1/8" steel (3mm+) at either 1500 or 1600 mm/min about 45A

Please Log in or Create an account to join the conversation.

More
28 Feb 2021 04:38 #200371 by rodw

thanks for quick reply - these THC tests were run on 1/8" steel (3mm+) at either 1500 or 1600 mm/min about 45A


Exactly. Just to be clear. THC Velocity lock (or corner lock) is enabled if the current velocity is a certain threshold percentage below the cut velocity (where cut velocity = book speed). Normally we would set the threshold to be 80%-90%. I think I use 90%. You had it set to 40%

So I saw your max-velocity in your ini is 25 mm/second (1500 mm/min) so how are you going to cut at 1600mm/min? You can't! The Gcode might be accepted but it won't be achieved. Also, the currnet velocity needs to be at or near the feed rate (cut velocity) befor auto sampling and THC enabling is executed.

So your current velocity will always be less than the cut velocity feed rate so the THC can never be turned on.

You need to be able to get up to about 10500 m/min (175 mm/sec) to cover everything in your cut charts.
The following user(s) said Thank You: dvn4life1972

Please Log in or Create an account to join the conversation.

More
28 Feb 2021 09:58 #200383 by kramerda
Sounds like I've got a couple of issues. Let me paraphrase so I understand.....so its just the Max Velocity for XYZ in ini that's wacked.
1. For cutting movements the .Ini variables for X and Y max velocity need to be twice what I'm actually cutting at. i.e. cutting at 1500 mm/min set max velocity to 50 (mm/sec).
2. For Z axis THC same applies but that movement is likely slower (???) but ratio must exceed % threshold set by VAD. i.e. Z axis movement
750 mm/min set max velocity > 25 mm/sec. (2:1).
3. Like you said - set V Threshold % at something like 80 or 90 %.
4. Not sure about my cut chart settings - will have to read up on that topic - for now just testing on the 3mm steel.
Since my system with steppers is 'open loop' speed control I think i'll be OK if I can get the numbers here in line.
Thanks again - we'll give it a go today.

Please Log in or Create an account to join the conversation.

More
28 Feb 2021 15:54 - 28 Feb 2021 16:01 #200429 by kramerda
THANK YOU VERY MUCH. That fixed it - doubled all occurrences of max velocity from 25 to 50 mm/sec (1500 to 3000 mm/min). Left accelerations alone.
Attached is new .ini file
is it necessary to also double stepgen velocity if no backlash comp. used??

For future reference --- is the parameter MAX_VELOCITY there just to put a reliable boundary on the stepper motor limits or is there some other reason?
Dennis
Attachments:
Last edit: 28 Feb 2021 16:01 by kramerda.

Please Log in or Create an account to join the conversation.

More
28 Feb 2021 22:22 #200472 by rodw
Great to get you going.

You need to determine the maximum velocity your motor is capable of without loosing steps

You then need to determine the maximum accelleration your motor is capable of without loosing steps. I have found this is much more critical. It is when accelerating that the load is on the motor. When you get to speed, the load falls to about 30% of that used when accellerating (motor/driver dependent).

You need to test this in the real world as I found simple oscillating back and forth does not test it out.
I also found that when a motor gets hot, that is the time that it will start to loose steps.

You also need to heed the comments here and adjust
# The values below should be 25% larger than MAX_VELOCITY and MAX_ACCELERATION
# If using BACKLASH compensation STEPGEN_MAXACCEL should be 100% larger.
#increased from 31.25 to 75 and 8937.5 to 1000
STEPGEN_MAXVEL = 75.0
STEPGEN_MAXACCEL = 1000.0
The following user(s) said Thank You: dvn4life1972

Please Log in or Create an account to join the conversation.

More
28 Feb 2021 23:01 #200480 by kramerda
Thankyou - watching my Z axis stepper go back and forth during cutting is a thing of BEAUTY.
Now that everything is 'basically working' we'll tune and tweak it. Since my duty cycle is only one part at a time - pushing temp. on motors or drivers is not an issue. That said the dynamics is very important for 'accurate' parts, corners, etc. Nice catch on the STEP GEN values. Thanks.
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

Time to create page: 0.154 seconds
Powered by Kunena Forum