Pierce height would exceed Z axis maximum limit while ohmic probing

More
17 Apr 2021 11:34 - 17 Apr 2021 11:36 #206179 by bevins
I dont understand why I am getting this. It ran fine 3/4 through the project then this. It is happening alot cutting and I cannot find what is causing this. Why it the touch going all the way up to z limit. I cannot find what parameter to change to fix this.

I attached the config and I am using the latest QTplasmac but it was doing this before in other versions. I just dont know how to rectify it.

Pierce height is at .150 so I don't know what this message is about.





Attachments:
Last edit: 17 Apr 2021 11:36 by bevins.

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 12:08 #206180 by bevins
been playing with Z_HOME, still cant any file to run now.

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 12:10 - 17 Apr 2021 12:11 #206181 by snowgoer540
This will explain all of the error messages: Error Messages

Simply put, the error message means that from where it detected the top of the material, there is not enough room for the Z axis to move to the Pierce height (in this case an additional .150” from where it found the material). If there’s not enough room, it gives you an error rather than running your torch into the soft limit.

Your backup isn’t attached but I don’t think I need it. I’ve seen it where the ohmic probe setup acts like a capacitor and after a bit of cutting hovers around the high voltage threshold and falsely “trips”. You can see this by using Hal meter and monitoring the voltage while cutting.

This can also happen due to noise. You can use the halscope to just do a rolling plot of the ohmic voltage. I found that my thcad was “quietest” with no shield wires connected at all. YMMV

Id guess for this job it didn’t actually detect the material with the ohmic probe anyways due to the rustiness of the material (I only use ohmic on thin, clean metal) and it actually was falling back to the float switch. Its also possible you’re getting water in the torch and during the probe it’s “shorting out” and simulating touching the material at the beginning of the probe.

A workaround until you get it ironed out is to you disabled ohmic probe for this job. Also plot your voltage and check the noise at some point. I suspect the line may be noisy.
Last edit: 17 Apr 2021 12:11 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 12:55 #206184 by rodw
try going to the top of z axis travel (say its 4") then type G54 Z4 (or going to bottom of travel and doing G54 Z0)
It should be fine then. You will only need to do it once.
Plasmac assumes Z0 is at the bottom of the material and it took me a long time to come to grips with G54 not knowing anything about Gcode

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 13:19 #206186 by snowgoer540

try going to the top of z axis travel (say its 4") then type G54 Z4 (or going to bottom of travel and doing G54 Z0)
It should be fine then. You will only need to do it once.
Plasmac assumes Z0 is at the bottom of the material and it took me a long time to come to grips with G54 not knowing anything about Gcode


That is not correct. The component uses eoffsets in conjunction with Z MIN and Z MAX and keeps track of where you started from, where the material is, etc. It couldn't care less where you set G54 Z0.

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 13:37 #206188 by bevins

try going to the top of z axis travel (say its 4") then type G54 Z4 (or going to bottom of travel and doing G54 Z0)
It should be fine then. You will only need to do it once.
Plasmac assumes Z0 is at the bottom of the material and it took me a long time to come to grips with G54 not knowing anything about Gcode


That is not correct. The component uses eoffsets in conjunction with Z MIN and Z MAX and keeps track of where you started from, where the material is, etc. It couldn't care less where you set G54 Z0.


I have plenty of room above and below material.Max limit is at the top of the Z which is 6". It is doing all this while using clean metal also.

So I can finish it by disabling ohmic probe and setting Z0 at material top?

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 13:40 - 17 Apr 2021 13:41 #206189 by snowgoer540

I have plenty of room above and below material.Max limit is at the top of the Z which is 6". It is doing all this while using clean metal also.

So I can finish it by disabling ohmic probe and setting Z0 at material top?


I listed a few things to check out in my post above, as well as the suggestion to disable ohmic probe on this material because it appears to be thick and rusted. And in addition, I think your voltage is probably "accumulating" and causing false trips.

Again, G54 Z0 will have 0 effect on anything as far as QtPlasmaC is concerned.
Last edit: 17 Apr 2021 13:41 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 13:53 - 17 Apr 2021 14:04 #206190 by bevins
Yes I read that. I selected ignore ohmic probe and still got the message "Pierce height would exceed Z axis maximum limit while ohmic probing"

EDIT: My bad I got it. it worked disabling ohmic and used the float.

Thanks for the tip of using ohmic probing on thin material only.
Last edit: 17 Apr 2021 14:04 by bevins.

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 15:38 #206193 by bevins

This will explain all of the error messages: Error Messages

Simply put, the error message means that from where it detected the top of the material, there is not enough room for the Z axis to move to the Pierce height (in this case an additional .150” from where it found the material). If there’s not enough room, it gives you an error rather than running your torch into the soft limit.

Your backup isn’t attached but I don’t think I need it. I’ve seen it where the ohmic probe setup acts like a capacitor and after a bit of cutting hovers around the high voltage threshold and falsely “trips”. You can see this by using Hal meter and monitoring the voltage while cutting.

This can also happen due to noise. You can use the halscope to just do a rolling plot of the ohmic voltage. I found that my thcad was “quietest” with no shield wires connected at all. YMMV

Id guess for this job it didn’t actually detect the material with the ohmic probe anyways due to the rustiness of the material (I only use ohmic on thin, clean metal) and it actually was falling back to the float switch. Its also possible you’re getting water in the torch and during the probe it’s “shorting out” and simulating touching the material at the beginning of the probe.

A workaround until you get it ironed out is to you disabled ohmic probe for this job. Also plot your voltage and check the noise at some point. I suspect the line may be noisy.


I am not using ohmic3, I am using Ohmic2. Not the thcad but input into mesa.

Please Log in or Create an account to join the conversation.

More
17 Apr 2021 16:24 #206194 by snowgoer540

I am not using ohmic3, I am using Ohmic2. Not the thcad but input into mesa.


I don't understand what you're trying to tell me..?

Please Log in or Create an account to join the conversation.

Time to create page: 0.342 seconds
Powered by Kunena Forum