Powermax communications issue

More
01 Nov 2021 05:17 #224835 by CFE
Hi all,

I have upgraded to the latest version of QtPlasmaC on a 64-bit installation and nearly everything is working as it should. The only thing that doesn't work is RS485 communication with the plasma cutter. I have installed python-serial, and when I run 'pmx485-test' in a terminal I get this error :
plasma@plasma:~$ pmx485-test

/dev/ttyS0 is open...

qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 878, resource id: 10612443, major code: 40 (TranslateCoords), minor code: 0

Any ideas what is going on ? I am out of my depth here.

Cheers, Peter

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 05:58 #224837 by phillc54
Did you install python3-serial?

If you run a package (Buildbot) installation then it is part of the linuxcnc-uspace-dev package.

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 06:09 #224839 by phillc54
Oops, I misread... 

/dev/ttyS0 is open... means that the port is connected to the test script, you should then check the RS485 box which should connect the PowerMax.

The following is an odd Qt error from python3 I think it can be ignored.
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 878, resource id: 10612443, major code: 40 (TranslateCoords), minor code: 0

 

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 06:21 #224840 by CFE
Replied by CFE on topic Powermax communications issue
Hi Phil,

Yes, I got the latest updates, and it says python3-serial is the latest version. When I do 'pmx485-test' in a terminal and I click on the RS485 button I get this message :
"no reply while writing to plasma unit
check connections and retry when ready"

I have checked all the connections, tried different USB ports, turned the plasma cutter on and off a couple of times, but to no avail. It's a bit strange, the comms were working brilliantly before I updated to the 64-bit installation and the latest version.

Cheers, Peter
 

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 06:26 - 01 Nov 2021 06:29 #224841 by phillc54
If it is a USB device then normally it would apper in the test panel as something like /dev/ttyUSB0.

You can check the name by unplugging the device from the USB port then open a terminal and enter ls /dev/tty* then plug in the device and repeat the command which should show the name of the device as an additional name.
Last edit: 01 Nov 2021 06:29 by phillc54.

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 06:30 #224842 by CFE
Replied by CFE on topic Powermax communications issue
Hi Phil,

I will give that a go in the morning, thank you.

We're in Victoria but so busy that we got to work on Melbourne Cup day :(

Cheers

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 06:32 #224844 by phillc54

We're in Victoria but so busy that we got to work on Melbourne Cup day :(

Bummer ...

But I guess there is good and bad in that.

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 21:38 #224920 by CFE
Replied by CFE on topic Powermax communications issue
Hi Phil,

I have followed your suggestion, but there is no difference in the output of the devices between plugged in or not. I will check all the wiring again, although we didn't touch any of that between software changes.

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 22:10 #224923 by phillc54
If there is no change then it indicates that the device is not being found. What is the device?

Please Log in or Create an account to join the conversation.

More
01 Nov 2021 22:32 #224925 by snowgoer540
As a matter of sanity for you, I wanted to let you know that I use PMX485 comms on the latest version of QtPlasmaC, running on a 64-bit machine, and it's working over here...  Just saying that so you can at least feel better knowing it's not a software bug.

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.171 seconds
Powered by Kunena Forum