failure Huanyang VFD HY01D523B

More
15 Mar 2022 00:36 #237274 by andypugh
What is the current situation? Can you control the spindle via the link with Spindle Talker and not with LinuxCNC? Or does it not work with either?

Please Log in or Create an account to join the conversation.

More
15 Mar 2022 08:32 - 15 Mar 2022 08:46 #237306 by Manu663
Yes I can control the spindle via the link with Spindle Talker and not with LinuxCNC.

I get the below message through the console:

Found file (REL): ./custom.hal
vfd: device='/dev/ttyUSB0', baud=19200, bits=8, parity='none', stopbits=2, address=1, debug=1, PID=9584
Opening /dev/ttyUSB0 at 19200 bauds (none)
Found file (REL): ./joypad_V3.hal
read_setup: reading setup parameters:

query length = 6
hycomm query = [01] [01] [03] [05] [00] [00] [2C] [4F] 
query_ret = 8
response_lenght_computed = 8
waiting for message (8 bytes)...
WAIT_DATA(): comms time out


I've tried to to connect the cable with reversed polarity to check and the message is different (something like ERROR invalid crc received. I did not captured the whole message as I inverted again the wires to retrieve the initial (and right) wiring.
 
Last edit: 15 Mar 2022 08:46 by Manu663. Reason: Some more info added

Please Log in or Create an account to join the conversation.

More
15 Mar 2022 09:07 #237310 by andypugh
Can you set the VFD to 19200? It very much looks like the LinuxCNC driver is ignoring your request for 9600 baud.
The driver defaults to 19200 and it might just be easier to set the VFD to match.

Please Log in or Create an account to join the conversation.

More
15 Mar 2022 09:28 #237313 by Manu663
Yes i've also tried to set the VFD to 19200 bauds but i get the same result.

Please Log in or Create an account to join the conversation.

More
15 Mar 2022 10:03 #237314 by andypugh
I see that the driver is also showing two stop bits in the output, despite being set to 1 in the last loadusr line you showed.

Can you show your current loadusr line and the corresponding output from the driver? Something isn't adding up.

Please Log in or Create an account to join the conversation.

More
16 Mar 2022 17:06 #237477 by Manu663
First of all, thank you again Andy for not letting me down. I still don't have an encouraging result but not feeling alone is already a lot! 
I have made so many changes that I wanted to start again from the beginning.
Here's what I get:
  

 

The values on the VFD are as follows:
PD163: 1
PD164: 2
PD165: 3
PD1: 2
PD2: 2
and the jumper J1 is in the position V1

 
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Mar 2022 19:18 #237485 by andypugh
OK, I just checked mine (which works) and the settings are like yours.

I then have:
loadusr -W hy_vfd -d /dev/ttyUSB0 -r 19200 -b8 -pnone -s1  -t1

net amp-enable hy_vfd.enable
net spindle-fwd spindle.0.forward => hy_vfd.spindle-forward
net spindle-rev spindle.0.reverse => hy_vfd.spindle-reverse
net spindle-on spindle.0.on  => hy_vfd.spindle-on

net spindle-speed-abs spindle.0.speed-out-abs => hy_vfd.speed-command

net spindle-at-speed hy_vfd.spindle-at-speed spindle.0.at-speed

(Copied and pasted directly from the working system, inconsistent spacing and all)

Please Log in or Create an account to join the conversation.

More
16 Mar 2022 19:19 #237486 by andypugh
(Note that the amp-enable signal is set somewhere else in the HAL file...)

Please Log in or Create an account to join the conversation.

More
16 Mar 2022 20:34 #237492 by Manu663
uh oh... II never seen this amp-enable in my custom hal file !!!

Please Log in or Create an account to join the conversation.

More
16 Mar 2022 21:19 #237496 by andypugh
No matter. Use:
net vfd-enable joint.1.amp-enable hy_vfd.enable

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 0.265 seconds
Powered by Kunena Forum