D510MO

More
09 Jun 2011 11:41 #10389 by BigJohnT
D510MO was created by BigJohnT
I have a couple of D510MO's and right out of the box I get just under 10,000us latency which is good. After following some conversations on these I decided to see if I could improve on that. I pressed F2 at boot up and turned off hyperthreading and got the latency down to 7,800us... not bad.

John

Please Log in or Create an account to join the conversation.

More
09 Jun 2011 12:28 #10390 by piasdom
Replied by piasdom on topic Re:D510MO
Very good. that seems to be the hardest thing(for me) in emc to
accomplish. i get about 32,000. Congrats !

Please Log in or Create an account to join the conversation.

More
09 Jun 2011 12:57 #10392 by PKM
Replied by PKM on topic Re:D510MO
Jonh, is it with or w/o isolcpus ?

Please Log in or Create an account to join the conversation.

More
09 Jun 2011 16:14 - 09 Jun 2011 16:14 #10393 by BigJohnT
Replied by BigJohnT on topic Re:D510MO
That is without isolcpu, I did find this on the wiki site about grub2 and 10.04.

wiki.linuxcnc.org/cgi-bin/emcinfo.pl?The..._Parameter_And_GRUB2

and plan on trying that next just to see if it gains me anything.

And after running the latency test about 6 hours the max latency is 8,835.

John
Last edit: 09 Jun 2011 16:14 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 06:55 - 10 Jun 2011 07:00 #10403 by step4linux
Replied by step4linux on topic Re:D510MO
isolcpu should bring another improvement.
I have been running 2.4.6 on a foxconn dual atom board for a while with HT off and isolcpu 1.
I think there was never jitter well above 3 usec. EDIT: correction 5 usec
It might be I have not stressed it too much, only firefox.

Gerd
Last edit: 10 Jun 2011 07:00 by step4linux.

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 11:25 - 10 Jun 2011 11:28 #10406 by BigJohnT
Replied by BigJohnT on topic Re:D510MO
After 24 hours of running the latency test it was up to 9400us. I've just did the isolcpu as shown on the wiki so we will see what that does.

wiki.linuxcnc.org/cgi-bin/emcinfo.pl?The..._Parameter_And_GRUB2

Right off the start the latency is 5270us... we will see what we get after running a while.

John
Last edit: 10 Jun 2011 11:28 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 13:45 #10408 by step4linux
Replied by step4linux on topic Re:D510MO
Right off the start I was at 3 us, now after some hours I'm at 7.204.

I have a joypad connected by USB, and did also some files copying back and forth to a USB stick.
Used also firefox, every now and then.

What is your test bench, John ?

Gerd

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 14:35 - 10 Jun 2011 14:35 #10410 by BigJohnT
Replied by BigJohnT on topic Re:D510MO
step4linux wrote:

What is your test bench, John ?

Gerd


Gerd,

I don't understand your question...

John
Last edit: 10 Jun 2011 14:35 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 15:08 #10411 by step4linux
Replied by step4linux on topic Re:D510MO
I mean, how do you stress your computer, run additional software, attach additional devices, or anything else to force worst case latency

Please Log in or Create an account to join the conversation.

More
10 Jun 2011 16:16 #10412 by BigJohnT
Replied by BigJohnT on topic Re:D510MO
I don't do anything specific, just open a few things up... seems like over time you get a worse latency than if you actually do something.

John

Please Log in or Create an account to join the conversation.

Time to create page: 0.206 seconds
Powered by Kunena Forum