Axis short stop (very short) about every 15-20 sec. when cutting circle.

20 Mar 2018 12:12 #107595 by denhen89
Hello Guys,
yesterday for the first time on my cnc router i milled aluminium, because i wanted to see how the quality of the cut looks and of course i was courious about the accuracy.
I did cut an Hole (contour) with an 3.175mm end mill for aluminum (500mm/min feed, 0.5mm doc, 20.000rpm, ). The hole diameter should be 60mm and the circle of course 53.6mm.
To make it as short as possible: The quality of the cut looks pretty good, no grooves or anything which looks strange. The accuracy is not as i expected i would say. I do meassure with an old Mitutoyo digital caliper. Almost everywhere i get 59.98-60.00mm but at one spot 60.04-60.06mm.
Actually, its an quiet big diy cnc router (Size 3000mm x 1650mm // Travel: Y: 2600mm , X: 1257mm) and i would also say its pretty stiff (welded frame) when it comes to that light cuts like yesterday in aluminum, so i think there was no problem with flexing, but there was an other problem which i saw.

Problem: When cutting the circle, it runs smoothly and everything sounds pretty good, but then it has some kind of "stop for a short moment". I am not sure how i can explain it, but just as example, its like there would be no power for an millisecond. I first thought its the X axis, and something mechanically, because when i observed the X-axis ball screw, it was turning and then stopped for the short moment, but actually when counting the time from one stop to another, i saw that this happens even when the X-axis (on the gantry) is not moving for short time while chaning direction. I then observed the Y axis, and the same thing happens, short stop.

So, what i think now is that it is some electrical problem or the CAM configuration.
X and Y stops, so it cant be an mechanical problem, also it does not happen if i jog the axis manually. No stopping of the axis.
I then took of the VFD plug and run the program without cutting, because i had some EMI issues and thought maybe i am loosing steps or something, but nothing has changed, but without the spindle running i could even hear the stops.

I switched from Solidworks to Fusion 360 for CAD and CAM, because solidworks seems to be more difficult when it comes to CAM for an beginner.
In Fusion 360 CAM, i used 0.01 Tolerance and also later i tryed the smoothing filter and set it to 0.01mm. Dont ask me why i used that filter, i just tryed to figure out what causes the problem. I thought i could be that the Computer does not manage to calculate the G-code and thats why it has some lag about every 20 seconds (not everytime at the same spot), but the computer is (at least for LinuxCNC) pretty good and my Latency is about 5000-6000.

I think i will later cut an rectangle and check if the same problems appear.

I tryed to find an similar problem, but it seems to be nothing typical, so i hope you can help me out.
In attachment i uploaded the Fusion 360 Postprocessor Gcode and later when i am in my workshop i will also uploaded my HAL and INI file. I hope that helps

Please Log in or Create an account to join the conversation.

20 Mar 2018 13:12 #107599 by Todd Zuercher
Is everything halting or just one axis (at direction reversals)?

When milling a circle, one axis will appear to halt for a fraction of a second at the direction reversal. (And if you are using backlash compensation, there should be a tiny jerk in the middle of it.)

Please Log in or Create an account to join the conversation.

20 Mar 2018 13:24 #107600 by denhen89
Thanks Todd for your reply.

It seems that this happens not always at direction change. Also i am not using Backlash compensation or at least i didnt want to so it so i used the # sign before the backlash command (#backlash). I had also backlash problems some time ago, but that way because i did not preload my bearings of the rotating nut system correctly. I corrected it and also glued the gear wheels to the shaft with special glue for that kind of things (its same like loctite 648) and after that i meassured the backlash and there was actually no backlash or max. 0.01. When i tryed to compensate for that 0.01mm it went more bad than good, so thats why i then used the # before backlash command.

Maybe when i go soon down to my workshop i try to make an short movie and maybe it will be visible. It seems that this problem happens ones a round , but not in the same spot. I think that also both axis (X and Y) stopping in same time for the short moment.
Currently i drawing some workholding clamps and later i want to cut them out and i will see if the same problem happens when doing no circle milling.

Will reply on today and i hope with an short video. I think a video will tell much much then my explanation in words.

Please Log in or Create an account to join the conversation.

20 Mar 2018 13:35 - 20 Mar 2018 13:36 #107604 by Todd Zuercher
Maybe you could try to take a look at the velocity traces for the X and Y axis in Halscope like this.

That trace was done using your G-code file, run in a virutal machine, (the spikes in the trace are caused by latency spikes in the VM.)
Last edit: 20 Mar 2018 13:36 by Todd Zuercher.

Please Log in or Create an account to join the conversation.

20 Mar 2018 13:48 #107608 by denhen89
Thank you Todd.

I wil check that soon (will run the program without the spindle).
If i understand correctly, it means that it could be an problem with the Latency ? Is it possible to set the Latency wrong, e.g. too low? When i did the latency test it showed 5000-7000, but if i remember correctly over 6000 it went only when many youtube videos, glxgear and other things where running. When i do milling work, i do nothing on the computer. Only LinuxCNC is running, so in the stepconf i set it up to 5000 latency.

Please Log in or Create an account to join the conversation.

20 Mar 2018 14:04 #107609 by Todd Zuercher
It could be, but I doubt it would be caused by latency. It would have to be a really really bad spike to be human noticeable. Are you receiving a warning message(s) about latency overruns? If not, then it almost certainty isn't the problem.

Please Log in or Create an account to join the conversation.

20 Mar 2018 16:11 #107622 by denhen89
Forgot to send the message over an hour ago: I get no warnings.

So, some good news i would say.

The problem has to be at the G-code from Fusion 360 Postprocessor (i used the LinuxCNC Postprocessor settings which can be download from the official Fusion 360 site).

How i found it out: I created an new g-code for the same circle i milled yesterday, but this time with 0.1 tolerance instead of 0.01, but nothing has changed. I then choosed the LinuxCNC example g-code file "arcspiral.ngc" and there i had not problems at all. It worked very smooth. Of course its not the same milling work, but an circle movement, so i think the problem should be at the Fusion 360 G-code/postprocessor file.
If i compare the circle g-code from fusion 360 with the arcspiral g-code then i for me its different, i mean of course its different, but there are so many lines, which for sure is because its an spiral not an circle, so the positioning is never the same, but still the codes are used are not same as from Fusion 360.

I hope i am right with that, and that it can be fixed by using an different cam software or fix the problem with the postprocessor settings.

I courious what you say Todd.

Thanks in advance.

Please Log in or Create an account to join the conversation.

20 Mar 2018 16:33 #107624 by Todd Zuercher
I don't know, I'm not noticing any pausing when I run the file you posted above (runnin in a simulation on a VM).

I do not see any G64 settings in your file though and they can make a big difference in how a file runs. So it will run with what ever setting was previously set by another file or the default set by your ini. Try adding "G64" or "G64 P0.01" to the preamble line at the beginning of your Fusion 360 file (N10) and see if that makes any difference. The arcspiral.ngc example file uses G64.

Please Log in or Create an account to join the conversation.

20 Mar 2018 16:44 - 20 Mar 2018 16:48 #107625 by denhen89
Thank you very much.

Actually in my last post i wanted to ask if the problem has something to do with g64 / G61, because when i was looking for an similar problem i found that some poeple was writing about that, but i am an beginner and i actually know almost nothing about g-code.

I will try that soon and thanks for telling me where to put the G64.

Just an short question: Could you tell me which editor to use on linux to edit my .ngc file without chaning the format? Libreoffice opens my files and after chaning something the file does not work anymore.
(of course i tryed to find it through google, but actually i found no informations)

EDIT: Opened the file with mosepad and i edited it and also i could load it. Unfortunately it has make not difference when added G64:
so like that:
(T1 D=3.175 CR=0. - ZMIN=-11. - SCHAFTFRSER)
N10 G90 G94 G17 G91.1 G64
N15 G21
N20 G53 G0 Z0.
Last edit: 20 Mar 2018 16:48 by denhen89.

Please Log in or Create an account to join the conversation.

20 Mar 2018 17:12 #107627 by PCW
I get pauses running the F360 gcode on real hardware:


Please Log in or Create an account to join the conversation.

Time to create page: 0.254 seconds
Powered by Kunena Forum