Ethercat HAL driver

More
22 Feb 2020 20:57 #158236 by tommylight
Replied by tommylight on topic Ethercat HAL driver
Yup that should get rid of that 90 second wait.

Please Log in or Create an account to join the conversation.

More
22 Feb 2020 21:15 #158240 by jirkam
Replied by jirkam on topic Ethercat HAL driver
Hi
Still waiting 90 seconds. But I don't mind that much.
Rather, I need to solve the PREOP for EL4004.
If anyone had any advice I would be very happy.

Thank you.

Please Log in or Create an account to join the conversation.

More
22 Feb 2020 21:20 #158241 by tommylight
Replied by tommylight on topic Ethercat HAL driver
Strange, that always does it for me.
Maybe it is waiting for something else, but the only other thing i can think of it the network, and that usually waits a bit and it gets backgrounded so the boot process can continue.

Please Log in or Create an account to join the conversation.

More
22 Feb 2020 21:30 #158242 by jirkam
Replied by jirkam on topic Ethercat HAL driver
I edited:

- Avoid waiting time to start up network services
"nano /lib/systemd/system/networking.service" (change here "TimeoutStartSec = 5min" to "TimeoutStartSec = 1sec")

But I had to set 20 seconds. When it was less, the system did not connect to the Internet.
Maybe that's why she waits.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
23 Feb 2020 20:11 #158325 by chimeno
Replied by chimeno on topic Ethercat HAL driver
Hi @jirKam,
Can you try only this module?
Does TWINCAT3 work for you?
<masters>
  <master idx="0" appTimePeriod="1000000" refClockSyncCycles="1000">
    <slave idx="0" type="EK1100" name="EK1100"/>
    <slave idx="1" type="EL4004" name="EL4004"/>
   </master>
</masters>
greeting
Chimeno

Please Log in or Create an account to join the conversation.

More
23 Feb 2020 21:17 #158330 by jirkam
Replied by jirkam on topic Ethercat HAL driver
Hi @chimeno.
Thank you for your response.
The module itself is also PREOP.
Twincat I tried only version "2". But I couldn't connect. I also wondered if there is a problem in the module. I will try to download Twincat 3. Which version should I download? There are 10 pieces.
Thank you.
Jirka

Please Log in or Create an account to join the conversation.

More
24 Feb 2020 09:52 - 24 Feb 2020 10:27 #158367 by jirkam
Replied by jirkam on topic Ethercat HAL driver
Hi @chimeno
"It is OP" !!! :)

I tried "EtherCAT_Configurator" and found that "#define LCEC_EL4004_PID 0x0fc23052" in the "lcec_el40x4.h" file does not match.
I wrote "0x0fa43052". And it works.
But I still have errors when I start my PC. And I don't know what to do with it.
Can you advise me?
Thank you very much.
Jirka
Attachments:
Last edit: 24 Feb 2020 10:27 by jirkam.

Please Log in or Create an account to join the conversation.

More
24 Feb 2020 21:12 - 24 Feb 2020 21:36 #158421 by chimeno
Replied by chimeno on topic Ethercat HAL driver
Hi @Jirka
I am very happy that everything works, I only have EL4034, in relation to the error, it seems an error in the device number 5, although I am not sure why it gives you error when starting the PC.

Twincat I tried only version "2". But I couldn't connect. I also wondered if there is a problem in the module. I will try to download Twincat 3. Which version should I download? There are 10 pieces.

TwinCAT 3.1 – eXtended Automation Engineering (XAE) 3.1.4024.7

to see the error messages you can use the command
dmesg

greeting
Chimeno
Last edit: 24 Feb 2020 21:36 by chimeno. Reason: Edit

Please Log in or Create an account to join the conversation.

More
24 Feb 2020 21:26 #158422 by jirkam
Replied by jirkam on topic Ethercat HAL driver
Hi @chimero
Thank you very much for your support.
Where can I copy text that is on PC startup? I won't have to do .jpg.
Thank you very much.
Jirka

Please Log in or Create an account to join the conversation.

More
04 Mar 2020 06:10 #159150 by Sockheaven
Replied by Sockheaven on topic Ethercat HAL driver
Hi All,
I have been trying to get LinuxCNC working with EtherCAT and a Kollmorgen AKD Servo Drive.
I have been posting on this other thread:
forum.linuxcnc.org/27-driver-boards/3559...tall?start=60#159103

But I'm stuck on one last thing, and after sifting through this thread, you guys sound like the right audience. I didn't notice any other posts in here indicating the same problem though.

Basically I'm getting data to/from the drive, i started off using StepGen to control the AKD but now i'm using that project to cobble together an EtherCAT setup so i can update my mill and get rid of some signal issues i've got (low voltage parallel port).

Forgive the mess in the HAL/INI files, so don't assume anything is there on purpose and a bit is commented out. I had to use the SCALE HAL component to handle scaling (it's arbitrary right now).

The problem I have not been able to figure out is:
How do i get the EtherCAT/Can state machine to operate based on the enable/disable button in LinuxCNC?

My understanding is it's not a simple bit, the control word (which i have mapped in the pdo section) has to change a few values in sequence for the device to enable/disable, but i haven't found an example of anyone else doing that to enable/disable.

Anyone have an inkling what i'm missing?

File Attachment:

File Name: ecat_test_...3-04.hal
File Size:5 KB

File Attachment:

File Name: ecat_test_...3-04.ini
File Size:2 KB

File Attachment:

File Name: ethercat-c...3-04.xml
File Size:5 KB
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.205 seconds
Powered by Kunena Forum