usb485 to huanyang vfd

More
24 Feb 2020 01:37 #158348 by tjones
Replied by tjones on topic usb485 to huanyang vfd
I am setting up another huanyang VFD with a 7i96 and 2.9. I have been following the above and my previous build. So far I can run the "halcmd loadusr" command and the "halcmd spindle enable" and when I use the "halcmd show pin" I can verify that it is true. So I think I am good with the USB to VFD connection. However when I go to open my config I get error on spindle waitpid and then hy_vfd has been exited without becoming ready. Any ideas?

Please Log in or Create an account to join the conversation.

More
03 Mar 2020 13:00 #159073 by andypugh
Replied by andypugh on topic usb485 to huanyang vfd
You may need to configure the VFD for ~modbus communications.

Can you paste the exact error messages?

Please Log in or Create an account to join the conversation.

More
03 Mar 2020 14:36 #159080 by bbsr_5a
Replied by bbsr_5a on topic usb485 to huanyang vfd
hi
i did also face problems on 2.9 from a recent 2.8 on the vfd
putting everything from the main HAL to a postgui Hal did solve almost all externel invirerment problems
the new interpreter is very triggy on externel in and out signals to the main hal system even on servotread
the postgui seams to be handled mutch more timing friendly as it has been in 2.7.x

Please Log in or Create an account to join the conversation.

More
05 Mar 2020 00:16 #159231 by tjones
Replied by tjones on topic usb485 to huanyang vfd
Attached is a picture of the error messages, as well as my cusom.hal file and custom_postgui.hal

File Attachment:

File Name: custom_2020-03-04.hal
File Size:1 KB

File Attachment:

File Name: custom_pos...3-04.hal
File Size:0 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
05 Mar 2020 20:54 #159279 by andypugh
Replied by andypugh on topic usb485 to huanyang vfd
There should be a button at the bottom of the error dialog that lets you copy all the text to paste into a text editor, or directly in to a message here.

But if I had to guess I would say that the driver is not finding the VFD.

Are you sure you are configuring the serial port correctly?

Please Log in or Create an account to join the conversation.

More
05 Mar 2020 21:05 #159282 by tjones
Replied by tjones on topic usb485 to huanyang vfd
Last time when I set up the VFD once I has able to run the following (which is just straight copied from the custom.hal file) in the terminal and verify the connection was good, I was able to get axis to load. But this time I can run the following in the terminal just fine. Seems like every other time I plug in my USB it switches between USB0 and USB1, so I have been updating that before I start, just using ls /dev/tty* to verify I am on the correct port. I will post the entire error message next time I try it.

- halcmd loadusr -Wn spindle-vfd hy_vfd -S 24000 -F 400 -n spindle-vfd -t 1 -d /dev/ttyUSB1 -p none -r 19200 -s 1 -g
- halcmd setp spindle-vfd.enable 1
- halcmd show pin

Please Log in or Create an account to join the conversation.

More
05 Mar 2020 21:21 #159285 by andypugh
Replied by andypugh on topic usb485 to huanyang vfd

Last time when I set up the VFD once I has able to run the following (which is just straight copied from the custom.hal file) in the terminal and verify the connection was good, I was able to get axis to load. But this time I can run the following in the terminal just fine. Seems like every other time I plug in my USB it switches between USB0 and USB1, so I have been updating that before I start, just using ls /dev/tty* to verify I am on the correct port.


There are ways to make the port name consistent:
indilib.org/support/tutorials/157-persis...al-port-mapping.html
(first google hit)

Please Log in or Create an account to join the conversation.

More
05 Mar 2020 21:33 #159288 by tjones
Replied by tjones on topic usb485 to huanyang vfd
Thanks, I will setup that up. I just haven't super cared until I can get axis to work.

Please Log in or Create an account to join the conversation.

More
12 May 2020 03:01 #167451 by tjones
Replied by tjones on topic usb485 to huanyang vfd
It has been awhile but I finally getting time to work on this again. I am looking through my HAL configuration in axis and if I look in Pins -> motion I don't have any motion.spindle Is this a problem? I believe these are required to run the spindle or at least that is what it required last time I set it up in 2.7.

Please Log in or Create an account to join the conversation.

More
12 May 2020 12:50 #167510 by andypugh
Replied by andypugh on topic usb485 to huanyang vfd

I am looking through my HAL configuration in axis and if I look in Pins -> motion I don't have any motion.spindle Is this a problem?


If you are running 2.8 then the motion.spindle pins have been renamed to spindle.N.pins as part of multi-spindle support.

Please Log in or Create an account to join the conversation.

Time to create page: 0.117 seconds
Powered by Kunena Forum