Water Jet 5axis using Parker servo drive what mesa board setup?

More
02 Feb 2023 19:58 #263544 by PCW
Yes, the drawing on the the right clearly shows
the drive running in analog (torque or velocity) mode
with simulated encoder feedback to the controller.

Please Log in or Create an account to join the conversation.

More
02 Feb 2023 20:23 #263546 by evocncinc@gmail.com
Thank you PCW ! very glad to know I have option with this machine eventually when the MESA card arrive :)

I will start installing LinuxCNC , do I have special packet to download or the driver card and linux 2.8.4 is ok ?

Please Log in or Create an account to join the conversation.

More
03 Feb 2023 20:32 #263619 by COFHAL
Peter
From what I understand, the 7i96s card could be used to control an analog servo motor with speed control with +- 10 volts, or am I wrong? I ask because in another thread you commented that it was not recommended to use that output control of a spindle to control analog servos because the response was very fast.

Please Log in or Create an account to join the conversation.

More
03 Feb 2023 20:40 #263623 by PCW
The 7I96S has a unipolar 0V to 18V Max output intended
for VFD spindle control. It is not intended for servo control as it
is slow (100 Hz or so bandwidth) and unipolar.

Please Log in or Create an account to join the conversation.

More
03 Feb 2023 20:52 #263625 by COFHAL
Thanks, it's clear to me.

Please Log in or Create an account to join the conversation.

More
03 Feb 2023 20:55 #263626 by COFHAL
Thanks again for your support. The problem I have is that I am going to use the 7i96 card because some ICs that control the STEPs are damaged and precisely the only one that I could not repair was the STEPS, it would be possible to compile a firmware to use STEP3.
I have another question, have you thought in the future to make a version of for example the 7i96s that has a single output to control an analog AC servo with +- 10 volts. For example, with the 7i33AT card I am only going to use one of the four available. Currently I am using some Chinese servo motors to replace the motors that are used with the spindle and the only way to control it is by DIR/PULSE and the drivers of these servos have inputs for control by +- 10 volts. Or even to use old Drivers for servo motors that only have +-10 volts as a control method. I am currently using a PARKER model MPA 07 servo driver and I can only control it like this.

Please Log in or Create an account to join the conversation.

More
03 Feb 2023 21:03 - 03 Feb 2023 21:19 #263627 by PCW
The 7I96S analog out is really intended for VFDs and there is not enough
need for +-10V outputs to justify the added complexity and cost.

I have considered a 1 channel +-10V analog +misc I/O + encoder
sserial card for this type of spindle application.


Have you considered step/dir for spindle control? , no added hardware needed.

Also,  its overkilll, but a 7I83 will give you 6 Analog +-10V outputs fully isolated from the 7I96S
Last edit: 03 Feb 2023 21:19 by PCW.

Please Log in or Create an account to join the conversation.

More
03 Feb 2023 22:06 #263634 by COFHAL
As I told you, now I only have a MPA 07 driver that only receives a control signal with +- 10 volts, I already installed a servo motor in my mini lathe and I control the speed with DIR PUL without problems, I can also control oriented spindle and others. The 7i33 card has arrived and I want to do some tests with the 7i96 card that I have available and that with your help I was able to repair, except for STEP 04, you recommended me a firmware that I could use with the 7i33, but only through STEP 04 and I have it damaged, that's why I required a version in which I could use STEP 03. In the future I could use another card to use the 4 analog interfaces of the 7i33.

Please Log in or Create an account to join the conversation.

More
07 Mar 2023 15:39 #266027 by evocncinc@gmail.com
Hello , I need some info on how to update the firmware of my 7i96s to be able to see the 7i77 ... 5v power , led on both cards , communication green led (4) light on 10.10.10.10 ping ok , mesaflash --device 7i96s --addr 10.10.10.10 --write 7i96s_7i77d.bin , then i have a error ''checking file...invalid bitfile header!'' , what command line should i write ? I think I have the lates install of Debian and Linux , i did some command for Mesa master ? need some help now lol

Please Log in or Create an account to join the conversation.

More
07 Mar 2023 16:26 #266037 by PCW
You would need a recent mesaflash:

github.com/LinuxCNC/mesaflash

(build instructions on bottom of page)

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.092 seconds
Powered by Kunena Forum