Keine Reaktion auf Schalter *gelöst*

More
04 Mar 2019 14:23 #127698 by pl7i92
Replied by pl7i92 on topic Keine Reaktion auf Schalter
Du must erstmal sicher sein wie was Verkabelt ist

ZB so
siehe pdf anhang

Da legen die Achsne alle auf den Datenpins 2/3 4/5 6/7 JEWEILS DIR PULS
und Die Enables liegen alle an einem Relai((extern)) welches an pin 14 Hämgt

This browser does not support PDFs. Please download the PDF to view it: Download PDF

Attachments:

Please Log in or Create an account to join the conversation.

More
04 Mar 2019 14:42 #127705 by spicer
Replied by spicer on topic Keine Reaktion auf Schalter
Es geht im Moment nur um die Schaltereingänge.
Die Schaltereingänge sind bei meinem Board auf den Pins 10-13 am LPT.
Wie gesagt werden sie von PortTest korrekt gelesen.
Nur LinuxCNC sieht die nicht.

Please Log in or Create an account to join the conversation.

More
04 Mar 2019 14:58 #127706 by pl7i92
Replied by pl7i92 on topic Keine Reaktion auf Schalter
Wenn der Port nicht Stimmt geht garnichts

Hier der Schaltplan
für die Schalter damit verlierst du keine PIN
du hast sowieso zu wenig
wenn du 10Eruro investiert hättest wäre alles OK mit dem originalboard #
www.ebay.de/itm/5-Axis-MACH3-CNC-Breakou...-Driver/302753680883

This browser does not support PDFs. Please download the PDF to view it: Download PDF

Attachments:
The following user(s) said Thank You: spicer

Please Log in or Create an account to join the conversation.

More
05 Mar 2019 18:34 #127812 by spicer
Replied by spicer on topic Keine Reaktion auf Schalter
Habe das Board wie von Dir empfohlen bestellt.
Dachte nicht, dass das so günstig ist.
Eine Frage dazu:
Sind die 12-24V Einspeisung nicht nötig, wenn man den USB für die 5V verwendet?
Im Datasheet heisst es da "optional".

Please Log in or Create an account to join the conversation.

More
06 Mar 2019 07:51 #127868 by pl7i92
Replied by pl7i92 on topic Keine Reaktion auf Schalter
Die 12-24V sind für die Inputs und den VFD


irgendwo ist das auch in Deutsch auf dem Schulrechner werde da Heute mal Nachschauen,und Hochladen
The following user(s) said Thank You: spicer

Please Log in or Create an account to join the conversation.

More
06 Mar 2019 08:13 #127871 by Clive S
Replied by Clive S on topic Keine Reaktion auf Schalter

Habe das Board wie von Dir empfohlen bestellt.
Dachte nicht, dass das so günstig ist.
Eine Frage dazu:
Sind die 12-24V Einspeisung nicht nötig, wenn man den USB für die 5V verwendet?
Im Datasheet heisst es da "optional".


These boards need the 12-24v connected for the inputs to work. They will not work without the 12-24v.

The data sheet is wrong. The optional bit is meaning the usb or the external 5v input. Not the 12-24v
The following user(s) said Thank You: spicer

Please Log in or Create an account to join the conversation.

More
06 Mar 2019 10:35 #127876 by pl7i92
Replied by pl7i92 on topic Keine Reaktion auf Schalter
Yes they all copy from the Same PDF that has this missliding advice

Please Log in or Create an account to join the conversation.

More
21 Mar 2019 21:09 - 21 Mar 2019 21:42 #129217 by spicer
Replied by spicer on topic Keine Reaktion auf Schalter
Es ist zum verzweifeln.
Habe heute endlich das BOB wie von Dir empfohlen erhalten.
Genau das gleiche.
Der PortTester zeigt die Schalterstellungen an. LinuxCNC (HAL anzeigen) nichts.
In der PortTester hal steht
loadrt hal_parport cfg="0xd8f8 out"
Im maschine.hal steht nirgends eine Adresse, obschon ich die im Stepconf Wizard eingetragen habe.
Wenn ich
loadrt hal_parport cfg="0xd8f8"
von Hand im hal File eintrage, startet LinuxCNC nicht mehr und dmesg zeigt:
HAL: ERROR: duplicate variable 'parport.0.pin-01-out'
Müsste nicht die Adresse oben im hal File stehn?
Im Anhang das erstellte hal File vom Wizard.
Attachments:
Last edit: 21 Mar 2019 21:42 by spicer.

Please Log in or Create an account to join the conversation.

More
22 Mar 2019 02:26 #129241 by tommylight
Die adrese ist in ordnung, da haben sie zwei mal die selbe pin im hal irgendwo.

Please Log in or Create an account to join the conversation.

More
22 Mar 2019 19:41 #129278 by spicer
Replied by spicer on topic Keine Reaktion auf Schalter
Peinlich. Hab den Fehler gefunden.
Hatte einen Hacken bei "Create simulated hardware configuration" drin.

Jetzt folgt das nächste Problem.
Der Motherboard interne LPT wird nicht mehr angezeigt mit lspci -vv.
Nur noch die nachträglich eingebaute.

Please Log in or Create an account to join the conversation.

Time to create page: 0.126 seconds
Powered by Kunena Forum