Enable Signal am Schrittmotoren Treiber

More
30 Mar 2022 10:25 #238701 by Muecke
Hallo miteinander,

ich habe ein Denkfehler in meinem Maschinen Aufbau bezüglich der Schrittmotoren Endstufen.

Verwendete Treiber: Motoren-Steuerung Endstufe für 1 Achse - SK8060 - 2- 6 A / 24-80 VDC

Was ich Denke:
Das Enable Signal bekommt 5VDC und der Treiber ist Aktiv.
Das Enable Signal bekommt keine 5VDC der Treiber ist Deaktiviert.

Daher habe ich folgendes gemacht.
Jeder Achse am Anfang und ende einen Mikroschalter (Öffner) verbaut und das Enable Signal durchgeschleift.

Mesa OUT 5V ==> Mikroschalter (Anfang ==> Mikroschalter (Ende) ==> ENA Treiber Achse

Doch die Annahme ist Falsch gewesen.
Richtig:
Das Enable Signal bekommt keine 5VDC und der Treiber ist Aktiv.
Das Enable Signal bekommt 5VDC der Treiber ist Deaktiviert.

Das macht mein Sicherheitskonzept kaputt!
Ein Kabelbruch kann nicht erkannt werden.
:-(

Habt Ihr eine Alternative Idee?
(Kurzfristig, keine Dauerlösung) ich ersetze die Mikroschalter von Öffner zu Schließer.

Doch wie mach ich das mit dem Kabelbruch erkennen? das ist ein elementarer Bestandteil meines Konzeptes.


Gruß Mücke

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 10:39 - 30 Mar 2022 10:41 #238704 by spicer
Das gegen Masse geschaltet wird, ist häufig in der Elektronik.
Du kannst die Öffner sein lassen.
Nur gehst Du mit der Masse auf die Schalter (common) (vielleicht kannst Du sogar gleich auf das Maschinengehäuse).
Wahrscheinlich haben die SK8060 einen Pullup Widerstand intern integriert. Finde gerade nur nichts darüber.
Das merkst Du sofort, wenn die SK8060 disabled sind, wenn der ENABLE Anschluss in der Luft hängt.
Last edit: 30 Mar 2022 10:41 by spicer.

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 11:15 #238709 by Muecke
Ich verstehe nicht richtig wie du es meinst wie man das nun verbinden soll.

Aktuell ist es so angeschlossen.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 11:55 #238715 by spicer
Hast mir mal einen Link zu Deiner Mesa Karte?
Ich kenne das Mesa Zeugs nicht so gut ^^

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 12:00 #238716 by Muecke
Selbst verständlich.

ich verwende die Mesa 7i95
habe das Handbuch auch hier im Original und ins Deutsche übersetzt.
 

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 12:04 #238717 by spicer
Ist das nicht das, von Deinem Beitrag: forum.linuxcnc.org/42-deutsch/44845-mesa...5-eingang-mit-taster

Sourcing Input?

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 12:07 #238718 by Muecke
ja und nein.
Das was du verlinkt hast ist der Schalter den ich dort noch zusätzlich verbaut habe um LinuxCNC mitzuteilen das ein Notaus-der-Achse ausgelöst wurde.

Ich habe das jedoch für mich so umgemünzt das ich auch die ENA Signale der Treiber entsprechend angeschlossen habe.

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 12:22 #238720 by spicer
Am SK8060 ENA+ auf 5V hängen und der Draht vom Öffner (welcher gegen Masse schaltet) an ENA-
Fragt sich jetzt nur, ob Du auch gleich ein Notaus-Signal an die Mesa schicken willst.

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 12:28 #238722 by spicer
Anstatt
Mesa OUT 5V ==> Mikroschalter (Anfang ==> Mikroschalter (Ende) ==> ENA Treiber Achse
so:
Mesa Ground ==> Mikroschalter (Anfang ==> Mikroschalter (Ende) ==> ENA Treiber Achse

Please Log in or Create an account to join the conversation.

More
30 Mar 2022 12:44 #238725 by roland
Warum hast du am Anfang und am Ender der Achse einen Schalter?
Üblichwerweise braucht man einen Referenzschalter pro Achse. Die Maschine macht nach dem Einschalten eine Referenzfahrt und weiß dann wo sie steht.
Mach dir das doch nicht unnötig schwer.
The following user(s) said Thank You: strahlensauger

Please Log in or Create an account to join the conversation.

Time to create page: 0.202 seconds
Powered by Kunena Forum