NPN Sensor wird nicht erkannt

More
28 Apr 2022 08:58 #241445 by Muecke
Hallo miteinander,

Ich habe einige NPN Sensoren verbaut, doch einer wird nicht erkannt, egal an welchem Eingang.

Sensor: INI-AB-I-025-E-AA ==> www.igus.de/product/17829?artNr=INI-AB-I-025-A-AA

Ich habe überprüft:

Brau = 24V DC +
Blau = 24V DC GND
Schwarz = Signal

Nicht geschaltet
Schwarz gegen 24V DC + == 24V
Geschaltet
Schwarz gegen 24V DC + == 1,9 V

Ist der Sensor defekt? oder ist das Normal?

Gruß Mücke

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 09:02 #241447 by tommylight
Welche karte oder BOB?

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 09:05 #241448 by Muecke

Welche karte oder BOB?
 

Bei mir ist die Mesa 7i95 im Einsatz.

Nach deiner frage urteile ich das der Sensor nicht defekt ist.

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 09:30 #241449 by rodw
Replied by rodw on topic NPN Sensor wird nicht erkannt
1.9 volts is less than the logic on/off threshold voltaage so it should be all good.

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 09:45 #241451 by spicer
Kannst ja zum Testen mal eine Drahtbrücke von GND auf den Eingangs-Pin der 7i95 machen und schauen, ob dir LinuxCNC den Eingang als logisch 1 anzeigt.

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 10:19 #241453 by Muecke
Aufgebaut habe ich das so:


Aufbau mit Sensor
Mesa TB6-3 [In GND 0, 1] <==> GND 24V DV 
Mesa TB6-2 [Input 1]     <== Signal Sensor
     [hm2_7i95.0.inmux.00.input-01]

Signal Sensor [Blau]     <==> GND 24V DC
Signal Sensor [Braun]    <==>   + 24V DC


HAL-Meter (TEST)
Mesa TB6-3 [In GND 0, 1] <==> GND 24V DV 
Mesa TB6-2 [Input 1]     <== 
HAL-Meter: FALSE
Mesa TB6-3 [In GND 0, 1] <==> GND 24V DV 
Mesa TB6-2 [Input 1]     <==  GND 24V DC
HAL-Meter: FALSE
Mesa TB6-3 [In GND 0, 1] <==> GND 24V DV 
Mesa TB6-2 [Input 1]     <==    + 24V DC
HAL-Meter: TRUE

Sensor Test:
Mesa TB6-3 [In GND 0, 1] <==> GND 24V DV 
Mesa TB6-2 [Input 1]     <== Signal Sensor
     [hm2_7i95.0.inmux.00.input-01]

Signal Sensor [Blau]     <==> GND 24V DC
Signal Sensor [Braun]    <==>   + 24V DC
Nicht ausgelöst!
HAL-Meter: FALSE

Ausgelöst! (LED am Sensor ist aus)
HAL-Meter: FALSE

Ich habe das noch an 3 weiteren Eingängen getestet, immer das Selbe Ergebnis :-(

Wie bekomme ich das in den griff?
oder ist der Sensor doch Defekt?

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 12:03 #241463 by itsme
Replied by itsme on topic NPN Sensor wird nicht erkannt
NPN Sensor:
Hast du einen pull up Widerstand drin? Zwischen VCC und Signal...

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 12:27 #241475 by Muecke

NPN Sensor:
Hast du einen pull up Widerstand drin? Zwischen VCC und Signal...


NEIN, sollte ich das?
Alle anderen Sensoren habe ich auch so angeschlossen. :-) ist das Falsch?

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 13:38 #241481 by itsme
Replied by itsme on topic NPN Sensor wird nicht erkannt
Ja, solltest Du!
Ein NPN schaltet gegen Masse. Ohne einen Pull Up hast Du kein Bezugspotential.
Das es bei den anderen Sensoren funktioniert ist purer Zufall und nicht reproduzierbar!
Siehe auch:
www.innovating-automation.blog/pnp-und-npn-sensor/?lang=de

Please Log in or Create an account to join the conversation.

More
28 Apr 2022 14:06 #241484 by Muecke

Ja, solltest Du!
Ein NPN schaltet gegen Masse. Ohne einen Pull Up hast Du kein Bezugspotential.
Das es bei den anderen Sensoren funktioniert ist purer Zufall und nicht reproduzierbar!
Siehe auch:
www.innovating-automation.blog/pnp-und-npn-sensor/?lang=de
 

Oh man, dann muss ich da noch einen Pull Up mit einbauen.

1.) Dann muss ich mich jetzt schlau machen wie ich den Berechnen.

2.) ich muss an den Mesa INPUT Pin demnach mit dem Signal vom Sensor und einen Pull Up - GND 24VDC zusammen anschließen.
Ich hoffe das ich das so richtig verstanden habe.

bei den Anderen Sensoren handelt es sich um die LJ12A3-4-Z/AX da das im anderen Thema so gewesen ist, dachte ich das das bei dem einen auch so ist. :-) *Falsch gedacht*
forum.linuxcnc.org/42-deutsch/44862-mesa...ngang-mit-npn-sensor


 

Please Log in or Create an account to join the conversation.

Time to create page: 0.150 seconds
Powered by Kunena Forum