Stepper-Encoder an einem Stepper via Parallelport nachrüsten

More
15 Aug 2023 19:43 - 15 Aug 2023 20:03 #278070 by Jensner
Hallo Leute,

ich ärgere mich nun seit gut einem Jahr damit herum, dass meine Z-Achse im Laufe des Fräsprogramms schrittweise verstellt und somit langsam immer tiefer ins Werkstück eintaucht. Die Achsen X + Y sind völlig unauffällig. Nach langem Testen, Optimieren diverser Parameter in Fusion (Fertigen) u.A. deaktivieren des Schnellvorschubs, Werkzeug unten halten" und extremem verringern des Accelleration Parameters in der ini ist das Problem zwar besser, aber immer noch existent.

Da meine Steuerung (Lewetz StepMax4 - über Parallelport) leider nur normale Stepper ansteuern kann, benötige ich eine Option zumindest an der Z-Achse mittels eines Encoders oder gleiche eines Closed Loop Motors ein Closed Loop System zu implementieren.

Es wäre ganz toll, wenn mir jemand einen Tipp geben, wie ich dies (ohne kompletten Umstieg auf MESA-Karten) umsetzen könnte?
Ich habe in meinem Steuerungsrechner aktuell 2 Parallelport-Karten verbaut von welchen nur eine für die Steuerung benötigt wird.
An der Zweiten wären noch Anschlüsse frei.

Vielen Dank schon mal
Viele Grüße
Jens  
Last edit: 15 Aug 2023 20:03 by Jensner.

Please Log in or Create an account to join the conversation.

More
15 Aug 2023 19:55 #278071 by meister
Hi Jens,
ja es geht, aber du solltest das vielleicht erstmal so hinbekommen das es auch ohne funktioniert, entweder sind deine motoren zu schwach, die feedrate zu hoch oder es klemmt was.

Ansonsten, schau dir mal 'MKS SERVO57C' an, das sind closed loop controller,
die gibt es für NEMA17 und NEMA23,
sie werden auch nur per step/dir gesteuert und laufen bei mir super.
Gibt es auch als set mit motor.

Gruß,
Olli

Please Log in or Create an account to join the conversation.

More
15 Aug 2023 20:22 - 15 Aug 2023 20:27 #278076 by Jensner
Servus Olli,

vielen Dank für Deinen Tipp.
Mir wäre es auch lieber die Ursache zu finden.
Klemmen tut da nix, ich habe heute (nach den anderen Anpassungen) testweise auch mal einen ordentlichen Gummi-Expander an die Z-Achse gespannt um die ca. 7kg (Spindel, Platte, Lager) Druck wegzunehmen. Dies hatte keinerlei Auswirkungen. Die Kugelumlaufspindel hat ne 5mm Steigung, der Stepper ist auch kein Kleiner (3A wie Nema23) der muss das locker schaffen.

Dann habe ich auch noch eine Markierung auf der Kupplung und Halterung gepinselt. Da hat man schön gesehen, dass das keine stetigen Schrittverluste waren, sondern alle paar Minuten ein größerer Schritt von ein paar Zehntel.

Gruß Jens

PS: Ich habe soeben meinen alten Fred vom letzten November wieder gefunden.
Damals ging es um das gleiche Problem. Ich dache jedoch damals, dass das Problem mit dem Accelleration-Parameter gelöst wäre. Leider nicht.
forum.linuxcnc.org/42-deutsch/47410-z-ac...raesprogramms#257051
Last edit: 15 Aug 2023 20:27 by Jensner.

Please Log in or Create an account to join the conversation.

More
15 Aug 2023 20:39 #278078 by spicer
Abschirmung überall sauber?

Please Log in or Create an account to join the conversation.

More
15 Aug 2023 21:02 #278081 by Jensner
Das könnte ein Ansatzpunkt sein, zumal das Kabel zum Stepper der Z-Achse schon ordentlich lang ist, da die Fräse relativ groß ist. Ca. 7m Kabellänge dürften das schon sein.

Auf der X- und Y- Achse habe ich übrigens noch nie ein Problem bemerkt...
Gleiches Kabel, nur eben kürzer (Y ca. 5m)

Gruß Jens

Please Log in or Create an account to join the conversation.

More
15 Aug 2023 23:58 #278099 by tommylight

Das könnte ein Ansatzpunkt sein, zumal das Kabel zum Stepper der Z-Achse schon ordentlich lang ist, da die Fräse relativ groß ist. Ca. 7m Kabellänge dürften das schon sein.

Auf der X- und Y- Achse habe ich übrigens noch nie ein Problem bemerkt...
Gleiches Kabel, nur eben kürzer (Y ca. 5m)

Gruß Jens

Am mindesten 1.5mm2 kabel fuhr solche lange.
Wen moglich 2.5mm2 ist besser.

Please Log in or Create an account to join the conversation.

More
16 Aug 2023 04:28 #278113 by spicer
Das Z Achskabel ist zudem noch parallel zum Fräs Motorkabel im Kabelschlepp.

Please Log in or Create an account to join the conversation.

More
16 Aug 2023 05:27 - 16 Aug 2023 05:29 #278115 by Jensner
Alle 3 Stepper-Kabel sind geschirmte Ölflexleitungen mit 4 x 1,5mm²
Auch das Fräsmotorkabel ist ein geschirmtes 4 x 2,5mm².

Gruß Jens
Last edit: 16 Aug 2023 05:29 by Jensner.

Please Log in or Create an account to join the conversation.

More
16 Aug 2023 05:46 - 16 Aug 2023 05:47 #278116 by spicer
Zwischen BOB und Treiber auch gut?
Schirm mindestens auf einer Seite angeschlossen?
Last edit: 16 Aug 2023 05:47 by spicer.

Please Log in or Create an account to join the conversation.

More
16 Aug 2023 06:17 - 16 Aug 2023 07:54 #278119 by Jensner

Hi Jens,
ja es geht, aber du solltest das vielleicht erstmal so hinbekommen das es auch ohne funktioniert, entweder sind deine motoren zu schwach, die feedrate zu hoch oder es klemmt was.

Ansonsten, schau dir mal 'MKS SERVO57C' an, das sind closed loop controller,
die gibt es für NEMA17 und NEMA23,
sie werden auch nur per step/dir gesteuert und laufen bei mir super.
Gibt es auch als set mit motor.

Gruß,
Olli
 


Hi Olli,

Der MKS Servo57C sieht schon mal interessant aus.
Die Frage ist nur wie ich diese dann ohne MESA-Karte, optimalerweise via Parallelport ansteuern kann.
Mit "Schritt und Richtung" hört sich das ja schon mal sehr gut an, denn dies läuft ja mit der aktuellen Steuerung auch via Parallelport.
In welcher Konstellation hast Du diese Konfiguration denn laufen?

Gruß Jens
Last edit: 16 Aug 2023 07:54 by Jensner.

Please Log in or Create an account to join the conversation.

Time to create page: 0.117 seconds
Powered by Kunena Forum