Update qtplasmac to latest with system from buildbot

More
13 Jun 2022 15:47 #245076 by bevins
I have an older QTPlasmac system I need to get updated to the latest version. 
Problem is it was built with buildbot. I am afraid now that it probably wont work if I try to upgrade linuxcnc with the troubles with the buiodbot right now.

What are my options?
It is running master 2.9.0-pre0.3879.g9a26e69fe
Linux Mint 19.3
python 3.6.9
python 2.7.17

Please Log in or Create an account to join the conversation.

More
14 Jun 2022 06:29 - 14 Jun 2022 23:42 #245101 by phillc54
Buildbot packages require python 3.7

To use the Buildbot packages you would require a distro with python 3.7 - Buster or MX19 are two that are known to work.

If you want to stick with Mint you will need to build locally and have two options for that.

Build for Run In Place:


Build a local package and install it:

Currently the no-docs option in package builds seems to have issues so you will probaly need to build the docs as well.

Edit: the no-docs option has been fixed.
Last edit: 14 Jun 2022 23:42 by phillc54.

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 06:48 #246051 by CFE
Well bugger,

I thought I update QtPlasmaC to the latest version but of course that broke the thing, now I see this thread. Wish this python 3 thingy was announced in the update list :(.

Is it possible to install python 3 on buster ?

Cheers, Peter

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 07:06 #246052 by CFE
I have tried rolling back to an earlier version, but that seems not to work this time due to this python 3.7 requirement for buildbot. Stuck with a dead machine now. How can I get this to work ?

Cheers, Peter
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 07:09 #246053 by phillc54
Buster should have python3.

What is the result of entering python3 at a command prompt?

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 07:16 #246054 by CFE
Hi Phil,

I just installed python-3.7.9, but QtPlasmaC still throws an error. If I type "python3.7 -V" in the terminal it shows Python 3.7.9

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 07:21 #246055 by phillc54
python 3.7 should have been the default python3 in Buster, LinuxCNC has required that for several months now.

What error are you getting?

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 07:21 #246056 by CFE
I saw in the error report whether "python3-gst1.0" is installed and I have tried to install that, but it seems the system is unable to locate that package. I suppose that doesn't help
 
Attachments:

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 07:25 #246057 by CFE
Here is the error report

Please Log in or Create an account to join the conversation.

More
28 Jun 2022 07:25 #246058 by phillc54
The package name is python3-gst-1.0
buster:~ $ apt search python3-gst
Sorting... Done
Full Text Search... Done
python3-gst-1.0/oldstable 1.14.4-1+b1 amd64
  GStreamer GObject Introspection overrides for Python (Python 3)

Please Log in or Create an account to join the conversation.

Moderators: snowgoer540
Time to create page: 0.085 seconds
Powered by Kunena Forum