Mitsubishi VFD Modbus cant get it work

More
11 Jan 2022 06:52 #231406 by cmorley
I don't know.
But here is the version you want:

github.com/LinuxCNC/linuxcnc/blob/2.8/sr..._comps/mitsub_vfd.py

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 06:59 #231408 by hitchhiker
ok. i give it in some hours a try.

how i can uninstall the loaded py3 mitsub_vfd?


if i have py 3.7 and the file from github... do i only need install or do i need more?! compile? dont know...


thanks

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 07:28 #231410 by cmorley
py 3.7 is not used for linuxcnc 2.8

overwrite the py3 mits sub with the one I posted a link to.

Did you compile linuxcnc ?

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 07:41 #231411 by hitchhiker
compile???i installed it from a iso ...

put in,boot, install.. to a complete empty hdd.

you mean delwte all mitsub_vdf files i can found and install the py2 version?

do i need halcompile -- install mitsub_vfd.py only or halcompile --compile?!


thanks for your help!!!

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 14:06 #231443 by cmorley
yes delete the old mitsub add the py2 one.

tell me where you found it in your system.
I don't ever use an installed version so will need to check where it needs to go.
if it's in the right place you don't need to compile it.

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 14:14 #231446 by hitchhiker
i found it not. i installed it from the download folder.

after this i found it in linuxcnc shared or something like this..

u understand?

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 15:07 #231451 by hitchhiker
is there a function to search a filename to the complete filesystem?

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 16:39 #231458 by hitchhiker
intersting thing... i go to usr/bin and find the mitsub_vfd

this mitsub_vfd have python2 in first line and is 447 lines long.

the one you told me to install is 390 lines long....

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 17:47 #231463 by hitchhiker
ok... now i got error...


no serial interface found at ttyusb0

its ch341.... sudo dmesg | grep tty shows me ch341-uart converter now attached to ttyusb0

solution???
its a big step to get this error..but why?!

Please Log in or Create an account to join the conversation.

More
11 Jan 2022 18:44 #231467 by jpg
Hello, look at this link, I hope it could help you:
forum.linuxcnc.org/38-general-linuxcnc-q...-emc-please?start=40

Please Log in or Create an account to join the conversation.

Time to create page: 0.107 seconds
Powered by Kunena Forum