Set up using AMC AB15A100 drives, brushed DC motor Prototrak Plus with Encoders

More
09 May 2022 23:50 #242431 by andypugh
Without LinuxCNC running, open a terminal.

halrun
loadrt hostmot2
loadrt hm2_pci
show pin
exit

Copy and paste the output here.
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
10 May 2022 00:11 #242436 by new2linux
andypugh, Many thanks!! The file is attached/inserted.  

File Attachment:

File Name: halrunError.txt
File Size:20 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
10 May 2022 23:37 #242537 by andypugh
It hasn't found the 7i77. The most likely explanation is that field power is not being supplied to the IO board section.
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
10 May 2022 23:59 #242542 by new2linux
andypugh, thank you for your help!! A new 24 v DC power supply will arrive this weekend, around the 14th. The A-M-C engineer is traveling early this week.

Many thanks for all the help & suggestions.

Please Log in or Create an account to join the conversation.

More
11 May 2022 19:38 #242666 by new2linux
The transformer arrived early, & I installed it today. The error message is close to the same, see attachment.

Many thanks!!
All suggestions are warmly welcomed.
Attachments:

Please Log in or Create an account to join the conversation.

More
11 May 2022 21:53 #242680 by andypugh
Is the 7i77 connected? Are you sure that the DB25 cable is a good one, fully wired, and not a cheaper "printer cable"?
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
11 May 2022 22:51 #242687 by tommylight
Most probably the 7i77 is working and found by LinuxCNC, but something is amiss with the scaling, also probably missing in the ini file.
I had this error before, so to do a quick check, just omit that line in hal for now.
With no power to the 7i77 it will complain about not finding analogout0 with no "scalemax" in the line.
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
11 May 2022 23:23 - 11 May 2022 23:26 #242690 by new2linux
tommylight & andypugh, Many, many thanks for your help. Is there a way to, or I may be thinking of something else. Is it "Re" or another way to leave the line in and have it not recognized?

Please remember, TB-5 (Pins 1 & 2) and A-M-C SW-1 (Pins that will be used are 2 (Signal GND) & 9 (Inhibit/Enable)) on the driver are not connected. These pins are the pins that make it move, but unsure of their proper final location. A-M-C's engineer will be returning soon. As I recall, a check of some kind is needed to know the exact final diagram.

DB25 cable; the cable I am using is the same cable from the "back EMF" system, have not changed it.

Many thanks for all the help & support!!
Last edit: 11 May 2022 23:26 by new2linux. Reason: DB25, question

Please Log in or Create an account to join the conversation.

More
12 May 2022 00:06 #242693 by tommylight
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
12 May 2022 13:20 #242795 by new2linux
Many thanks, I found that line only 1 place & use # in front of it, but a similar error code, see attachment. Included is a copy of .ini file with #.

thanks!!
 
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 0.144 seconds
Powered by Kunena Forum