Mesa Configuration Tool

More
31 Aug 2022 11:28 #250852 by ajja
Mesa Configuration Tool was created by ajja
Hi,
thanks a lot for all the very helpful work,

Since I don't have a git account I am filing here a little bug report for the mesact configuration tool ( great stuff by the way !):

When trying to reopen the tool I got the following error:

File os.py line 225, in makedirs
["FileExistsError: [Errno 17] File exists: '/home/mitad/.config/measct'\n"]

It seems that /measct cannot be overwritten on reopening, if I delete the folder manually mesact opens normally.

Sorry if this report is not at the right place, feel free to move/delete it.

ajja
The following user(s) said Thank You: JT

Please Log in or Create an account to join the conversation.

More
31 Aug 2022 22:05 #250898 by JT
Replied by JT on topic Mesa Configuration Tool
Are you using the latest version of the Mesa Configuration Tool?

JT

Please Log in or Create an account to join the conversation.

More
31 Aug 2022 23:05 #250902 by ajja
Replied by ajja on topic Mesa Configuration Tool
yes latest version from master/ mesact_0.7.0_amd64.deb

Apparently it is because I didn't finish up to validation before closing the program the first time. Now that I have completed a configuration I don't get the error anymore

Please Log in or Create an account to join the conversation.

More
01 Sep 2022 12:56 #250920 by JT
Replied by JT on topic Mesa Configuration Tool
The latest is 0.7.1 Build Date 8/24/2022


JT
Attachments:
The following user(s) said Thank You: tommylight, Clive S, tivoi

Please Log in or Create an account to join the conversation.

More
05 Sep 2022 00:30 #251196 by joshwuh
Replied by joshwuh on topic Mesa Configuration Tool
FYI - not sure if it is intended to be a functioning tool yet but the latest tool appears to have a bug that prevents building the config file:

I set the bare minimum configuration to build the tool, and the last error is as follows:
Axes Tab
Multiple Joint Axis must be negative for at least one Joint.

That's with an XYZ configuration (no tandem axis). If I change it to an XYYZ configuration (joint 0,1,2,3 respectively) then it will change the error to something like:
Axes Tab
Multiple Joint Axis Y joint1 & joint2 must be negative for at least one Joint.

If you set scale to -1 OR reverse direction (but not both) you continue getting this error. If you set scale to -1 AND reverse direction you get a new, additional error stating that you must pick one or the other.
 

Please Log in or Create an account to join the conversation.

More
12 Sep 2022 13:55 #251737 by JT
Replied by JT on topic Mesa Configuration Tool
Yes it is my intention that the tool works and works above and beyond what other tools do.

Sorry about the bug, it has been fixed a couple of days ago.

JT

Please Log in or Create an account to join the conversation.

More
16 Sep 2022 16:38 #252087 by HansU
Replied by HansU on topic Mesa Configuration Tool
I wanted to create a configuration for a 5i25 + 7i85s.
It seems that the 7i85s is not fully supported yet.
I get this when trying to select the 7i85s:

And in the Axes tab it still says 7i77


Furthermore I wonder about the meaning of the bit/pin files in the 5i25/holding folder. Are those the not yet supported ones?
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Sep 2022 18:21 #252095 by JT
Replied by JT on topic Mesa Configuration Tool
Thanks for the feedback, I'll correct that in the morning.

Yes, as I add support for bit files I move them from holding.

JT

Please Log in or Create an account to join the conversation.

More
16 Sep 2022 20:36 #252116 by JT
Replied by JT on topic Mesa Configuration Tool
I fixed the errors and you "should" be able to configure your axes but didn't have time to test that. Download a fresh copy of the deb from the menu File > Download Amd64 Deb in mesact.

JT
The following user(s) said Thank You: HansU

Please Log in or Create an account to join the conversation.

More
17 Sep 2022 16:36 - 17 Sep 2022 16:37 #252177 by HansU
Replied by HansU on topic Mesa Configuration Tool
A comment on the commit "fix checking for linuxcnc version I hope"
If I set the localization to en, then it works for me. But with German locale if didn't work because your query gives this:
$ apt-cache policy linuxcnc-uspace
linuxcnc-uspace:
    Installiert: 1:2.8.3

Not sure how to get this fixed multilangual.
Last edit: 17 Sep 2022 16:37 by HansU.
The following user(s) said Thank You: JT

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.168 seconds
Powered by Kunena Forum