Bostomatic 400-2 Retrofit

More
19 Oct 2021 15:23 #223568 by JR1050
Replied by JR1050 on topic Bostomatic 400-2 Retrofit
I would like to buy the mdsi stuff you have , are you willing to part with it? Do you have the original disks?

Please Log in or Create an account to join the conversation.

More
19 Oct 2021 17:22 #223578 by nduerr
Replied by nduerr on topic Bostomatic 400-2 Retrofit
Let me look. I think the disk had water damage when I got it. Are you looking for the boards also?

Please Log in or Create an account to join the conversation.

More
12 Nov 2021 21:14 #226246 by nduerr
Replied by nduerr on topic Bostomatic 400-2 Retrofit
Being this is my first try at this I would like to go through the MESA jumper and flash setup.
The PC I have is Optiplex 7020 with the onboard NIC and a second PCI NIC, 250SSD & 16mb ram onboard video.
Here are the Jitter #'s
Servo 1038813 max int 39327 max jitter
Base 59602 max interval 34602 max jitter
Not as good as I was expecting but ok.
Any ideas to lower these, I am willing to give it a try.
I have everything mounted on a test board with 12V & 5V going to each corresponding supply pins.
For the 7I94:
jumpers W3-up, W2-up, W4-down & w5 up to set the ip to 10.10.10.10 (connecting to the PCI NIC set to 10.10.10.6)
I need to mesa flash using the 7I94-7I89 config that was posted on a different thread.
The 7I89 I will start off with the default jumpers. I believe this should work with my 2000puls/rev quadrature encoders that I have. I will also have to set pin 41 on the 7I94 to true to see the 7i89 pins.

Out of Serial 1 & 2 of the 7I94 will be the 2 7I83's to run my servos and spindles.
Going to use default jumpers for the 7I83's.

Out of Serial 3 of the 7I94 will be the 7I90HD. Jumpers: W1-up, W3-up, W4-remove, W6-up. I know I need to mesaflash this so it will work with the serial input from the 7I94 and have all 3 50pin connectors be IO pins (to connect directly to the WRC relay IO boards) but I am unsure which one? Any recommendations? Can I flash this card thru the 7I94 or do I connect directly to the NIC to flash?

Out of Serial 4 of the 7I94 will be the 7I73 panel connector. Jumpers: W5-down, W6-Down, W7-Down (no keypad or LCD) W10-up, & W11-up. I did get 3-32count encoders for the 3 override potentiometers. I am planning to run my mpg to the 7I89 (its already wired that way) so I can add more buttons to my panel in the future if I want.

Is there anything that I missed or should do differently?

Thanks for the help!

Please Log in or Create an account to join the conversation.

More
17 Nov 2021 21:37 #226789 by andypugh
Replied by andypugh on topic Bostomatic 400-2 Retrofit
Without poring over docs I can't tell if your setup is correct. But several days later, is it working?

Please Log in or Create an account to join the conversation.

More
18 Nov 2021 18:28 #226901 by nduerr
Replied by nduerr on topic Bostomatic 400-2 Retrofit
I haven't been able to work on it since my last post. I am fairly confident on the jumpers for the boards.
My biggest question is on the 7I90HD, how to flash it (directly with the NIC or thru the 7I94 card) and with what file to get IO on all pins?
My plan is to get this working this weekend and see if I can test out some pins etc.

Please Log in or Create an account to join the conversation.

More
21 Nov 2021 17:44 #227210 by andypugh
Replied by andypugh on topic Bostomatic 400-2 Retrofit
You would update the 7i90 via the 7i94, once it is flashed with a smart-serial firmware.
Do you know which firmware is on the 7i90? I suspect that the default firmware might be the parallel-port one.

I think that I have seen other forum posts here about how to configure the 7i90 as a smart-serial device.

Do you have communications with the 7i94 from LinuxCNC / HAL?

Please Log in or Create an account to join the conversation.

More
21 Nov 2021 19:18 #227221 by PCW
Replied by PCW on topic Bostomatic 400-2 Retrofit
If you requested a 7I90 with sserial remote firmware loaded
It should have been shipped from Mesa with the firmware preloaded
in the secondary EEPROM ('S' jumper position )
The 7I90 should have had a label on the bag indicating this firmware setup

You cannot flash 7I90 SSerial remote firmware via the sserial connection

Please Log in or Create an account to join the conversation.

More
22 Nov 2021 01:09 #227260 by nduerr
Replied by nduerr on topic Bostomatic 400-2 Retrofit
Yep, I missed the sserial tag. That would explain why the W3 jumper was in the down "S" position. So if I have read the manual correctly after it boots up and with power on, I should move the W3 jumper to up " P" position and that will re-write a copy of the secondary memory to the primary memory and then boot from the primary copy with the next boot. Do I have that correct?

andypugh - I am going to flash the 7I94-7I89 combo tonight and run thru the pncconf for the first time, assuming I can get connected to it!

Please Log in or Create an account to join the conversation.

More
22 Nov 2021 02:23 #227265 by PCW
Replied by PCW on topic Bostomatic 400-2 Retrofit
If the 7I90 has sserial firmware installed there is
nothing more needed for 7I90 setup

(just leave W3 in the 'S' position)

Please Log in or Create an account to join the conversation.

More
24 Nov 2021 04:51 #227476 by nduerr
Replied by nduerr on topic Bostomatic 400-2 Retrofit
I was able to ping, flash & check the 7I94-7i89 combo, but the connection drops after a few minutes. I thought it was a NIC, I had to load drivers for the NIC and im not sure they were correct. So I got a new Intel NIC and it loaded automatically and still have the same issue of the connection deactivating. I go to the nm-tray and start it back up and I can ping the 7I94 again. Anybody else see this or is this normal?

PCW... I misread the 7I83 input power connector and hooked it up in reverse, will this damage the card? I hooked it up correctly and connected it up to a 12V PC power supply for testing and the supply shuts off immediately. The supply works fine with the other boards connected and the 7I83's unplugged. Any Ideas?

I went through the PNCconf for the first time and used the 7I80HD for the initial setup. Id this the best method? Linuxcnc diden't launch, and after looking at the main hal file I see I have a lot of editing to do!

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.093 seconds
Powered by Kunena Forum