GladeVCP

More
13 Sep 2011 13:58 - 13 Sep 2011 14:08 #13169 by piasdom
Replied by piasdom on topic Re:GladeVCP
as far as the estop button, i tried 'control and display toggle and plain button.
and hal python toggleaction and hal_action_estop_reset1 and neither change state.
except toggleaction does turn power off once i turn on with other button.
and i have it connect with emc toggleaction estop in glade.
just to let you know in case a bug.


Thanks
kenneth
Last edit: 13 Sep 2011 14:08 by piasdom.

Please Log in or Create an account to join the conversation.

More
13 Sep 2011 14:14 #13170 by psha
Replied by psha on topic Re:GladeVCP
Show your UI file please.
And postgui halfile
BTW you are using estop reset action, not toggle action - they are different
ToggleAction consists of two actions - for on-off state change and for off-on

Please Log in or Create an account to join the conversation.

More
13 Sep 2011 14:26 - 13 Sep 2011 14:26 #13171 by piasdom
Replied by piasdom on topic Re:GladeVCP

File Attachment:

File Name: postguiHAL.txt
File Size:7 KB


Thanks
kenneth
Attachments:
Last edit: 13 Sep 2011 14:26 by piasdom.

Please Log in or Create an account to join the conversation.

More
13 Sep 2011 14:27 #13172 by piasdom
Replied by piasdom on topic Re:GladeVCP
piasdom wrote:

File Attachment:

File Name: postguiHAL.txt
File Size:7 KB


File Attachment:

File Name: GladeUI.txt
File Size:17 KB


Thanks
kenneth

Attachments:

Please Log in or Create an account to join the conversation.

More
13 Sep 2011 14:47 #13173 by psha
Replied by psha on topic Re:GladeVCP
Yes, you are using estop reset instead of estop toggle, that's why it's only turning off machine and not turning on

Please Log in or Create an account to join the conversation.

More
13 Sep 2011 14:57 #13175 by piasdom
Replied by piasdom on topic Re:GladeVCP
Thanks, i did use toggle and reset, guess it was reset that i last used.
but i think i found my blunder:) . in my axis.hal i had the
net estop-out => iocontrol.0.emc-enable-in disabled because i used it for
my prvcp button. after enabling it, estop works as should. sorry for giving
you all this trouble. Thanks so much !


Thanks
kenneth

Please Log in or Create an account to join the conversation.

More
13 Sep 2011 23:13 #13185 by piasdom
Replied by piasdom on topic Re:GladeVCP
the home all, each home XYZ buttons don't go disabled when program running.
letting u no





kenneth

Please Log in or Create an account to join the conversation.

More
14 Sep 2011 10:59 #13195 by piasdom
Replied by piasdom on topic Re:GladeVCP
where/how do i disable a button/pin while program is running,as in the attached txt ?
i want the home and move axis buttons to be disabled while program running.

File Attachment:

File Name: Disabling.txt
File Size:1 KB




Thanks
kenneth
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Sep 2011 11:46 #13222 by piasdom
Replied by piasdom on topic Re:GladeVCP
i can edit the the color of a label but not the size. the lettering disappears.
and can i edit the color/size of a button(reg/hal) ?


Thanks
kenneth

Please Log in or Create an account to join the conversation.

More
19 Sep 2011 10:51 - 19 Sep 2011 10:57 #13285 by piasdom
Replied by piasdom on topic Re:GladeVCP
what do i use for a pyvcp number widget ?
want to setup a DRO in glade. i tried the meter for a feed rate,
but it didn't match the feed.




Thanks
kenneth
Last edit: 19 Sep 2011 10:57 by piasdom.

Please Log in or Create an account to join the conversation.

Moderators: mhaberlerHansU
Time to create page: 0.148 seconds
Powered by Kunena Forum