How to. 2 or more motors on one axis. Gantry

More
16 Jul 2020 09:27 - 16 Jul 2020 09:29 #174818 by rsteurer1
Hello first sorry for my English
When i use 2 Y axis coupled are there some settings for the (Probe Screen V2) (Makros) ? because i think one doesn't turn wright at probing.

thx
other movements are fine
Last edit: 16 Jul 2020 09:29 by rsteurer1.

Please Log in or Create an account to join the conversation.

More
09 Sep 2020 10:57 #181411 by kevin19
Hello, I did almost the same to have my 2 steppers in the Z axis in linuxcnc 2.9 master version but I am getting the following error, can someone help me? I am also attaching my ini and hal files to this message.
Attachments:

Please Log in or Create an account to join the conversation.

More
09 Sep 2020 12:20 #181425 by Clive S

kevin19 wrote: Hello, I did almost the same to have my 2 steppers in the Z axis in linuxcnc 2.9 master version but I am getting the following error, can someone help me? I am also attaching my ini and hal files to this message.


for a start change this in the ini file

COORDINATES = XYZ to
COORDINATES = XYZZ
The following user(s) said Thank You: kevin19

Please Log in or Create an account to join the conversation.

More
09 Sep 2020 13:40 #181440 by tommylight
From your hal file:
loadrt stepgen step_type=0,0,0
should be
loadrt stepgen step_type=0,0,0,0
The following user(s) said Thank You: kevin19

Please Log in or Create an account to join the conversation.

More
09 Sep 2020 14:05 #181447 by kevin19
Thank you!

Please Log in or Create an account to join the conversation.

Time to create page: 0.213 seconds
Powered by Kunena Forum