Installation EMC on kubuntu 9.4/9.10

More
17 Mar 2010 05:18 #2332 by kilop
mozmck my configuration is:

AMD Sempron 2400+
1 GB ram
maninboard is asrock K7S41GX ( with disabled in bios onboard grafic card)
Nvidia Gforce 7300 GT 256 ram Palit

and always get black screen with blinking cursor :(

Please Log in or Create an account to join the conversation.

More
18 Mar 2010 13:36 #2354 by mr_deimos
cncready wrote:

this guide could help you by compiling the rtai kernel: www.timberline.se/?p=8
it worked fine for me

I have also installed the deb-packages and had the same problem with the black screen and the blinking cursor.

maybe the problem is that the kernel is compiled for a pentium M CPU...


Thanks a lot for that link. Unfortunately it works exactly the same as mozmick's kernel debs - just the blinking cursor. As if the kernel doesn't even start loading.
When i try to choose the rtai kernel in recovery mode from GRUB, i get linux image size and info displayed by grub (grub uses different video resolution than the linux console so it's easy to say which messages are from grub), then the video mode changes to the one used by linux console, and only the blinking cursor appears: no errors, it doesn't even seem to write anything to logs.
I'll try to follow that guide again, but use the newer kernel source and maybe try compiling before applying the rtai patch to see if it's a problem with the basic kernel configuration or rtai patches.

Please Log in or Create an account to join the conversation.

More
18 Mar 2010 19:32 #2356 by mozmck
For the black screen and blinking cursor, try the following.

Add this line to /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

if GRUB_CMDLINE_LINUX_DEFAULT is already there just add the nomodeset to it.

Then run 'sudo update-grub'

Then try booting from the kernel that wouldn't boot and see what happens...

Please Log in or Create an account to join the conversation.

More
19 Mar 2010 00:07 #2359 by mr_deimos
Well, adding the nomodeset parameter didn't help. Besides, i can see the blinking cursor, so graphic mode seems to be fine. Also, all hdd activity ceases after a few seconds from choosing the RTAI kernel in grub, so it seems that nothing is happening and it's not just a matter of not being able to see it ;)

I tried to compile the stock (no rtai patches) 2.6.31.8 kernel as described in the guide mentioned by cncready, and it did boot. Didn't play nice with "nvidia" driver and i had to switch to "nv", but that's a small problem that could probably be fixed later. The most important part is it did start loading. However, after compiling the same kernel with the same configuration, but with RTAI patches applied it no longer booted.
I tried compiling with both the default 586 cpu setting and with Opteron/Athlno64/Hammer/K8 setting. In both cases stock kernel worked, the RTAI didn't.

So it would seem that either the RTAI patch, or some config setting related to rtai causes a failure on my hardware configuration. I think i'll try again tomorrow with patches from magma branch of rtai. Or are the patches the same as volcano version?

Please Log in or Create an account to join the conversation.

More
19 Mar 2010 03:04 #2361 by mozmck
magma has a patch for 2.6.32.7 which vulcano does not have yet.

did you remove the "quiet" option when you added "nomodeset"? I think it has "quiet" by default and that suppresses messages. I don't know what else to say right now. If you find a setting that lets you boot with rtai patches let me know what it is, and I'll be looking around for more information too.

Moses

Please Log in or Create an account to join the conversation.

More
19 Mar 2010 16:12 #2372 by mr_deimos
Yep, i removed both "quiet" and "splash" that were sitting there by default.
I compiled the 2.6.31.8 kernel with pretty much the default config (copied one from/boot and used that as a starting point) and using pathes from magma branch - no joy.
2.6.32.7 kernel is compiling right now. We'll see what happens. I do have some programming experience in both windows and linux environments and i do know a few things about linux, but must admit i'm moving around in the dark right here since i don't have any experience with custom kernels. So i'm just trying different versions, different config options and keeping my fingers crossed :P
What really puzzles me is that when i tried to compile rtai kernel for archlinux i couldn't get it to run because it had trouble with my sata controller (couldn't detect any hard drives). But the error message about no hdd's detected at least gave some starting point for debugging. Here i have nothing to base on, no starting point, not a single error message.
I tried to compare my hardware with kilop's - he seems the only one besides me who reported this problem and i can't really see any common parts - different chipsets, different cpu families, even different gpu generations.
That's weird and a bit frustrating too. But i've already played around with EMC on a laptop and i really like it :) As a laptop it had terrible realtime performance and that's why i'm trying to put EMC on a desktop PC. So i guess i'll just have to keep on trying :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.167 seconds
Powered by Kunena Forum