Configure PlasmaC with only one BOB

More
16 Apr 2021 02:08 - 16 Apr 2021 08:38 #206078 by phillc54
Can you confirm the following:

You do not have a breakaway switch.
You do not have a float switch.
You are using "parport.0.pin-11-in-not" for all-home and also for ohmic-probe-input.

What version of LinuxCNC are you using?

Edit:
You seem to be using an old version of PlasmaC, the debounce component was changed to the new dbounce component on September 11 last year.
Last edit: 16 Apr 2021 08:38 by phillc54.

Please Log in or Create an account to join the conversation.

More
18 Apr 2021 18:54 #206321 by Giuseppe
YES (will come later)
YES (will come later)
YES

Version is 2.8.0

Please Log in or Create an account to join the conversation.

More
19 Apr 2021 01:38 #206347 by phillc54
Try the two attached files, hopefully I got it correct. There are a couple of comments in the testplasmacnc_connections.hal that are dependant on whether you need a "in" or "in-not" for ohmic probing.
It is best when using PlasmaC to keep all your plasma specific connections in the testplasmacnc_connections.hal file which allows you to use StepConf to change config settings without changing any plasma connections.
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: phillc54
Time to create page: 0.090 seconds
Powered by Kunena Forum