User Install for Probe Basic Py3 (For Machine Control)

More
29 Apr 2023 22:29 #270251 by ihavenofish
I did that as per rodw's instructions yes.
There was another gui related option i left default. But i see online perhaps it should have been the other one. Can't remember what it was now.

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 22:34 #270252 by Lcvette
the only change is uncheck gnome and check xfce4, no other changes!

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 22:43 #270253 by ihavenofish
k. well, then what went wrong.

The only other notable screw up i had was after installing linuxcnc, I lost sudo privileges from my account and switched to root. Realised that does not work, figured out how to reinstate sudo, then continued.

Would that break something? Put something in the wrong spot?

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 22:51 #270256 by Lcvette
yes, when installing linuxcnc leave root password blank, then first time you run sudo apt update it will ask you to set the root password. this is used during the installation.

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 22:57 #270257 by ihavenofish
ok, im going to install in a few mins.
The following user(s) said Thank You: Lcvette

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 23:17 #270261 by Lcvette
cool, keep us posted

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 23:35 #270263 by ihavenofish
Curious. i now have a completely different linux gui - similar to the older linuxcnc one. clearly i pressed something wrong last time.

My brain hurts. haha.

Please Log in or Create an account to join the conversation.

More
29 Apr 2023 23:42 #270264 by Lcvette
You must not have been on xfce4 which likely accounts for the error, it looks like that because that was preset in linuxcnc distros

Please Log in or Create an account to join the conversation.

More
30 Apr 2023 00:08 #270267 by ihavenofish
wooo
seems to have worked. in addition t the ui, i think something was wrong with python last time. this time it gave me an error and told me to fix instal. after that it took a while to do various things, which it definitely didnt do before.

So the next thing is the config. am i right in that other pinned post is the instructions (something about merging the sim into the pncconf generated config?

Please Log in or Create an account to join the conversation.

More
30 Apr 2023 00:24 #270269 by Lcvette
read thoroughly the instructions here:

forum.linuxcnc.org/qtpyvcp/48401-configu...-for-probe-basic-py3

when you get to the ini file be sure you understand what is in that link for the ini is NOT all that is needed, it must be integrated into your newly spit out axis ini file.

once you get it all copied over it should startup and run on your machine .

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.174 seconds
Powered by Kunena Forum