ViaConstructor - Free and Opensource CAM for Linux and Mac

More
03 Mar 2023 23:17 #265809 by phillc54
I just tried on Debian Bookworm running Wayland.

Without an export the 3d view is transparent.

I opened a teminal as a normal user and entered the following two commands and it runs successfully:
export QT_QPA_PLATFORM="xcb"
./bin/viaconstructor tests/data/simple.dxf

Warning: Spoiler!


Warning: Spoiler!
Attachments:

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 11:38 #265836 by Dragonick
When I enter your commands, I get the following message:
bash: ./bin/viaconstructor: No such file or directory

And I searched and I can't find the viaconstructor folder anywhere

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 23:13 #265873 by phillc54
I installed directly from git as I was unable to successfully install via pip on any of my machines.:
git clone https://github.com/multigcs/viaconstructor.git
cd viaconstructor
pip3 install -r requirements.txt
export QT_QPA_PLATFORM="xcb"
./bin/viaconstructor tests/data/simple.dxf

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 01:45 #265892 by rodw

I installed directly from git as I was unable to successfully install via pip on any of my machines.:
git clone https://github.com/multigcs/viaconstructor.git
cd viaconstructor
pip3 install -r requirements.txt
export QT_QPA_PLATFORM="xcb"
./bin/viaconstructor tests/data/simple.dxf

Later versions of python I believe inhibit running pip unless you are in a virtual environment (VENV). Maybe that was your issue? python VENVs are kind of clever if you want to run seperate Python apps (say accounting and web server) as they mean you can run each in its own virtual python environment, But for everyday stuff its a pain in the rear.
random ref: www.freecodecamp.org/news/how-to-setup-v...ironments-in-python/

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 03:44 #265896 by phillc54
I have never had a reason to use pip but I thought that I would try considering that it is mentioned in the viaconstructor readme.

It didn't go well... lucky I don't need it.
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 20:32 #265939 by Dragonick
I receive this message:

Installing collected packages: pyqt5
  WARNING: The scripts pylupdate5, pyrcc5 and pyuic5 are installed in '/home/cnc/.local/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed pyqt5-5.15.7
cnc@cnc:~/viaconstructor$ export QT_QPA_PLATFORM="xcb"
cnc@cnc:~/viaconstructor$ ./bin/viaconstructor tests/data/simple.dxf
Traceback (most recent call last):
  File "/usr/lib/python3.7/runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/lib/python3.7/runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "/home/cnc/viaconstructor/viaconstructor/__main__.py", line 1, in <module>
    from .viaconstructor import ViaConstructor
  File "/home/cnc/viaconstructor/viaconstructor/viaconstructor.py", line 20, in <module>
    import ezdxf
ModuleNotFoundError: No module named 'ezdxf'
cnc@cnc:~/viaconstructor$

 

 
how to fix it ?
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Mar 2023 21:06 #265978 by Grotius
ezdxf is a python lib. Maybe install it, my suggestion without checking it : $ sudo apt-get install python3-exdxf
 

Please Log in or Create an account to join the conversation.

More
07 Mar 2023 12:06 #266021 by Dragonick
receives this message:
E: Unable to locate package python3-exdxf
 

and I messed up everything. because now viaconstructor does not open for me at all
 
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Mar 2023 23:44 #266084 by Grotius
Hi,

O my god. Welcome to Linux.

snapshot.debian.org/package/ezdxf/0.14.2-3/
Then it would be : # sudo apt-get install python3-ezdxf (you did'nt see my typo?)

packages.debian.org/bullseye/qtcreator
Then it would be : # sudo apt-get install qtcreator
has libqt5core5a (>= 5.15.1)

Hope this helps.

Please Log in or Create an account to join the conversation.

More
09 Mar 2023 18:41 #266226 by Dragonick
It still didn't work. Now I have this error
 
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: Skullworks
Time to create page: 0.242 seconds
Powered by Kunena Forum