XHC-WHB04B-6 LinuxCNC not working

More
21 Aug 2020 21:23 #178958 by satiowadahc
You may need to post more of your INI File.

However here's mine:

# Jog wheel and axis selection button
net jog-x axis.x.jog-enable <= xhc-hb04.jog.enable-x
net jog-y axis.y.jog-enable <= xhc-hb04.jog.enable-y
net jog-z axis.z.jog-enable <= xhc-hb04.jog.enable-z

Please Log in or Create an account to join the conversation.

More
21 Aug 2020 21:24 #178959 by satiowadahc
Odd, a page didn't seem to load and definitely replied to the wrong post.

Please Log in or Create an account to join the conversation.

More
24 Aug 2020 09:42 #179212 by OE5AMP
Hello

I installed LinuxCNC 2.8 with this image "cnc.beaglebrainz.net/cdimage/cnc-19.2.0-...ate-uspace-64bit.iso"

After that I wanted to install the wireless China handwheel according to Talla83's instructions. Formerly with Debian 9 the installation worked with its manual and the handwheel worked perfectly.
Unfortunately that didn't work with Linux Mint anymore.
When compiling I got a lot of errors. So I used the original LinuxCNC folder and recompiled everything.

The handwheel also works, but the machine jerks extremely when moving. With every setting

When I use the buttons in Axis everything works normally.

In the attachment my hal and ini files

Maybe someone can help me.

Thanks in advance

Greetings from Austria
Attachments:

Please Log in or Create an account to join the conversation.

More
24 Aug 2020 20:23 #179271 by diegojulio
Hello: Can you help me to compile the driver in 2.7 with Ubuntu 12.04 Precise? This can be done with this version?

Please Log in or Create an account to join the conversation.

More
25 Aug 2020 04:06 #179309 by anfänger
I also used Tallahassee version and it worked fine. What were the errors during compiling?

Please Log in or Create an account to join the conversation.

More
25 Aug 2020 16:25 #179405 by OE5AMP
Hello
Tomorrow I have to recompile the Talla83 driver again so that I can see what errors occur. I exchanged the folder from the Talla83 with the original folder and then compiled it

Please Log in or Create an account to join the conversation.

More
28 Sep 2020 17:43 #184187 by Uthayne

The handwheel also works, but the machine jerks extremely when moving. With every setting


I am in the same boat here. Using the built in driver with 2.9, continuous and step mode jogging with the wheel is very jerky on all settings.

The console reports timeout issues while spinning the jog wheel
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms
hal   failed to wait for reqested mode. waited 300ms

and watching whb.axis.x.jog-counts shows a lot of missed counts when turning the wheel with any sort of speed.

I was able to get the machinekit/talla83 driver working, but the continuous mode had a fixed jog-scale at 2.0. Step mode worked perfect, but I would wish for the feed rotary to adjust the speed percentage when in continuous mode. The built-in driver adjusts the jog-scale in continuous mode, but has the annoying problem of losing jog-counts.

Please Log in or Create an account to join the conversation.

More
28 Sep 2020 17:52 #184188 by andypugh

I am in the same boat here. Using the built in driver with 2.9, continuous and step mode jogging with the wheel is very jerky on all settings.


Have you tried adjusting the (new) axis.L.jog−accel−fraction pin?

linuxcnc.org/docs/2.7/html/man/man9/motion.9.html

Please Log in or Create an account to join the conversation.

More
28 Sep 2020 17:58 #184189 by Uthayne
I have not, I will give that a shot.

I was able to get both continuous and step mode to behave as expected by changing the timeoutMs to 0 in the below section of hal.cc and recompiled.
bool Hal::waitForRequestedMode(volatile hal_bit_t * condition)
{
    if(mIsSimulationMode)
    {
        return true;
    }
    useconds_t   timeoutMs   = 0;//mHalRequestProfile.mode.modeCheckLoopTimeoutMs;
    unsigned int maxTimeouts = mHalRequestProfile.mode.modeCheckLoops;
    unsigned int timeouts    = maxTimeouts;
    do
    {
        if (false == *condition)
        {
            usleep(timeoutMs * 1000);
        }
        else
        {
            return true;
        }
    } while ((false == *condition) && (--timeouts) > 0);
    if (false == *condition)
    {
        auto delay = (maxTimeouts - timeouts) * timeoutMs;
        std::cerr << "hal   failed to wait for reqested mode. waited " << delay << "ms\n";
        return false;
    }
    else
    {
        return true;
    }
    return false;
}

Although this has seemed to fix both issues (jerkiness and missed jog counts), I feel like it is not really a solution? I have been jogging around with it for the last few minutes and haven't seen any errors due to getting rid of the timeout duration. I'll have a look at adjusting the axis.L.jog-accel-fraction pin too.

Please Log in or Create an account to join the conversation.

More
28 Sep 2020 18:04 #184191 by romeofox
I solved my handwheel problem with a solution from the german cnc-aus-holz.at forum: link

At first I also suspected the USB port and system problems.
But I found the cause after searching the source code and several tests:
In the example configuration for the hand wheel (raw.githubusercontent.com/Linu.../example-configuration.md) the following signal connection is created in the section "#machine mode related signals":
net pdnt.mode.teleop whb.halui.mode.teleop halui.mode.teleop

But the signal "halui.mode.teleop" is not set by LinuxCNC as expected by the driver and then leads to timeouts/sleeps in the driver, which in turn leads to the delays when transmitting the handwheel movement to LinuxCNC.

After I changed the signal connection to :
net pdnt.mode.is-manual whb.halui.mode.is-teleop

where the net "net pdnt.mode.is-manual" is defined in the example config as:
net pdnt.mode.is-manual halui.mode.is-manual whb.halui.mode.is-manual
Did the hand wheel work without any problems.

Thanks to Ghostrider!

Please Log in or Create an account to join the conversation.

Time to create page: 0.161 seconds
Powered by Kunena Forum